XP Startup Error - "Services.exe - Application Error. (0xc0000005)"

I have a desktop running XP Home SP2 which throws up a Message on startup headed as

Services.exe - Application Error

The application failed to initialize properly (0xc0000005). Click OK to terminate this application.

This appears on a black background and can't be shifted and I then have to restart the machine manually.

So far I have tried..

Checking memory - no faults
safe mode
last known good, etc

I have booted into XP using ERD Commander and turned off all the programs set to start with Windows.

Tried a different version of Wininet.dll as it was suggested it might be corrupt.

Ctrl - alt - del repeatedly to try and get Task manager up.

All to no effect.

Anything else worth trying before I carry out a repair installation?

Who is Participating?
alfaroConnect With a Mentor Author Commented:
Problem solved...
I ran Malwarebytes on the disk while it was in another machine and it found and removed the following.

Files Infected:
H:\hcel.exe (Trojan.Downloader) -> Quarantined and deleted successfully.
H:\Documents and Settings\Martin\Application Data\SystemProc\lsass.exe (Trojan.Tracur) -> Quarantined and deleted successfully.
H:\Documents and Settings\Martin\Local Settings\Temp\9.tmp (Trojan.Tracur) -> Quarantined and deleted successfully.
H:\Documents and Settings\Martin\Local Settings\Temporary Internet Files\Content.IE5\CKKQCAMP\QuickTime_Update_KB638271[1].exe (Trojan.Tracur) -> Quarantined and deleted successfully.
H:\Documents and Settings\Martin\Local Settings\Temporary Internet Files\Content.IE5\W1QN4LMB\QuickTime_Update_KB524625[1].exe (Trojan.Tracur) -> Quarantined and deleted successfully.
H:\WINDOWS\system32\hccoin32.dll (Trojan.Tracur) -> Quarantined and deleted successfully.
H:\WINDOWS\system32\lTcydoRpfIvrx.vbs (Trojan.Agent) -> Quarantined and deleted successfully.
H:\WINDOWS\system32\fxswzrd32.dll (Trojan.Tracur) -> Quarantined and deleted successfully.
H:\WINDOWS\system32\dsuiext32.dll (Trojan.Tracur) -> Quarantined and deleted successfully.

When I replaced the drive in the original pc it started and no more error messages. I ran Malwarebytes on it again and found a few more bits and pieces and after updating the AV everything seems to be fine now..
alfaroAuthor Commented:
I can't install SP3 until I get XP started. The hard drive is being tested in another machine at present and I've already tested the memory and tried other sticks as well..

SFC will get a run after the drive has been tested..

[Admin Edit] is not allowed to be discussed in this forum......

UBCD would be a good alternative....

Does SAFE MODE work?

When you haev the error on screen, hit CTRL+SHIFT+ESC

Does the Task Manager popup?
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

alfaroAuthor Commented:
Safe mode brings up the same message. Will try Ctrl +Shift+ESC when the drive has been replaced in the pc...
alfaroAuthor Commented:
What's the problem with [Admin Edit] on this site?

[Admin Edit] has pirated software on it, and we do not condone that here.....
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.