• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 527
  • Last Modified:

Password authentication works for OWA but fails for Microsoft Outlook

I have recently install SBS 2008.  Outlook 2003 connects fine to Exchange however Outlook 2007
continues to prompt for authentication even though I can access the Exchange account and it
indicates that I am connected.  I have verified the UID/PW I am entering is correct using OWA
which works just fine.

I am even able to open shared resources such as calendars and contacts which indicates
that Exchange is indeed connected.

Please help.

1 Solution
This support article is for server 2000, but is still relevant:

What is rollup package installed on your server.
You should install at least updata rollup 9 SP1:
Most probably the cause is installed patch KB 973917.

You can also install SP2. The latest is update rollup 3 for SP2, but I would wait some day before installing it, because it is brand new and there is not enough feedback of potential problems. Do not install Update rollup 2 for SP2, because it has problems.

UR3 for SP2 is not listed yet. Here is the link:
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows PowershellĀ® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

And if you plan to install SP2, do not forget to use Microsoft Exchange Server 2007 SP2 Installation Tool for Windows SBS 2008:

I hope I have not forgotten something - again ...
Outlook 2007 is very particular about SSL certs. If you are using a self signed cert then you need to manually add it to the trusted root certification authority container using the MMC.
Open MMC
Add certificates snap-in
For the local computer
Click on trusted root certification authorities
Right click certificates and import your self signed certificate.
Then try Outlook again. Make sure you using domain\username for your login.
Sorry, do this on the workstation with Outlook 2007 installed.
jermc905Author Commented:
It appears that during the installation process a security certficiate was created with the local netbios name as well as the external FQDN to be used remote.domain.com.

When changing which cert was being used by Exchange 2008 for all servers IIS, POP, SMTP etc. the Exchange server would indicate that the name on the cert did not match the name of the server.

Long story short I enabled the FQDN cert for all services and redirected the autodiscover page to the FQDN site rather than the internal site.  Viola it worked.

Thank you for all of your suggestions.
Yes...but Where did you go to do all that!  What are the steps ?

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now