Allocated Memory Alert on SERVER email notifications on SBS 2003

We are running SBS 2003 w/ service pack 2 in our server. About a month ago I increased the RAM from 1gig to 2gig. Since then I have been receiving email alerts that state the following:

Allocated Memory Alert on SERVER

Alert on SERVER at 3/24/2010 11:40:58 PM

A large amount of memory is committed to applications and processes. Consistently high memory usage can cause performance problems.

To determine which processes and applications are using the most memory, use Task Manager. Monitor the activity of these resources over a few days. If they continue to use a high level of memory and are less critical processes or services, try stopping and then restarting them.

You can disable this alert or change its threshold by using the Change Alert Notifications task in the Server Management Monitoring and Reporting taskpad.

I opened Task Manager and found the following large memory users:

Store.exe      578,220k
Sqlserver.exe      498,224k
Services.exe      104,280k

Commit Charge 2349M/3944M

Does anyone have any ideas on what is causing this, and better yet, how to fix it?

Thanks,
Steve
SteveB2515Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SteveCommented:
I ran across an article about Exchange eating up memory if you have 2+GB.

This article explains it but in short, you need to optimize your memory.
0
SteveCommented:
0
HiltonParkCommented:
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

SteveB2515Author Commented:
Sorry for the long delay in writing. I wanted to make sure everything was working before closing the question.

I tried sodea63's solution first because it made the most sense, and I knew I could undo it if it didn't work. It worked well at first, but ultimately the memory usage continued to climb and I began receiving the error email again. I un-did that solution.

I was going to try HiltonPark's solution, however there were no instructions on how to undo it if it didn't work. HiltonPark's solution was actually posted on a blog page, and if I followed the blog as time went on, others reported that the memory issue returned as well. I chose not to try that solution.

Furthermore, both solutions date back to 2007, with an issue that popped up with service pack 1. It is now 3 years and another service pack later. I'm not even sure of those solutions are relevant anymore.

I have been trying to do more research on the net, but haven't found the golden nugget yet. If anyone else has anything to offer, please do.

Thanks,
Steve
0
SteveCommented:
I have the same setup with 2 gigs of ram, I will play around with it a bit more when I get a chance but I know my offered solution was for exchange and looking back your SQL server was eating up almost as much as exchange. If it is not slowing down too much try changing the warning level on memory usage. Raise the limits and watch the memory usage to see if it is still climbing. SBS is already asking a lot of one server to start with and SQL is not kind to memory as a rule. On top of that SBS has all of the extra wizards and backgroud reporting going on.
0
SteveB2515Author Commented:
Thanks for the follow-up. I did receive another warning email this morning. I just check the server. Here are the top 4 current memory users:

store.exe        MSExchangeIS     576,544
sqlservr.exe   MSSQL$SBSMONITORING   500,600
services.exe   103,036
w3wp.exe       53,468

Thanks,
Steve
0
SteveCommented:
From what you've posted in your logs, seems like you might have the warning set to 500,000. You might try raising it to about 600,000 as None of your processes have seemed to go above that.
0
SteveB2515Author Commented:
Thanks,

I received three more alerts in the early morning hours on Saturday. When I arrived at the office later that morning I took a look at the memory usage. The sqlservr.exe had climbed again to:

Store.exe       MSExchangeIS                   579,872
sqlservr.exe  MSSQL$SBSMONITORING 560,656
services.exe 103,084

I just looked at the Performance Counter. The Allocated Memory Alert says the following:
30-Day Average 1,772,816,791.2
Alert Threshold 2,147,483,648

Thanks,
Steve
0
SteveCommented:
If it happened during early morning hours and you weren't hacked, it was probably running a scheduled service like a backup. There is another setting for low un-used memory as well but that is not the error you are getting. I'd try bumping the alert threshold up a little bit every day or so until you stop getting the warnings or just delete them when you do. If it gets too resource intensive the Low memory warning will let you know.

Most of the fixes I have run across dela with limiting your memory for paticular applications but state that if you are not having problems due to lack of memory then the warning is quite normal.
Beyond that, see if you have the means to get SQL off that server.
0
SteveB2515Author Commented:
So here’s what I learned. The alert email is sent when a threshold is broken. The threshold on the server is based on its 30-day average memory usage.  But when you install more memory as I did, the server is going to use that new memory, that’s why it’s there. However, the alert threshold is still based on the original 30-day average, so you WILL get the email alert. I monitored my system closely and there were no unusual instances of programs using too much memory, just the usual store.exe and sqlserver.exe, but using more than before.

So my solution was this - each time I received an email, I went into the server and raised the threshold to 140% of the latest 30-day average as suggested in a Microsoft document I found, but unfortunately can’t re-find and link to. The server itself will show you the current 30-day average. I no longer receive the alerts.

To see the 30-day average and change the threshold, do this:

1.      From Server Management select Monitor and Reporting
2.      Select Change Alert Notifications
3.      Select the Performance Counters tab
4.      Double-click on Allocated Memory
5.      Change the threshold to 140% of the 30 day counter average


0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SteveCommented:

Two quotes from 2 of my posts:
1. I'd try bumping the alert threshold up a little bit every day or so until you stop getting the warnings or just delete them when you do. If it gets too resource intensive the Low memory warning will let you know.
and
2. If it is not slowing down too much try changing the warning level on memory usage.

The problem was fixed by raising the warning level threshold.
I will not object to the closing of this thead though.
0
HiltonParkCommented:
No Problem

Hilton
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.