How do I associate a new protocol with a program in firefox using linux?

I'm using arch linux, and I've tried a couple times to add new protocols to firefox but have failed, with firefox popping up with "Firefox doesn't know how to open this address, because the protocol (mms) isn't associated with any program."

For example I'm trying to get firefox to open mms with mplayer, and following the mozilla support page http://support.mozilla.com/en-US/kb/The+protocol+is+not+associated+with+any+program and other info found on the net added these two preferences to about:config:

network.protocol-handler.app.mms   /usr/bin/mplayer
network.protocol-handler.external.mms   true

It achieves nothing and I get the exact same error next time I click an mms link, even after restarting firefox. I can open the mms link from the command line with mplayer though. I has been bugging me for ages because it should be so simple but nothing I have found on the net will work.

By the way I want a general solution to this, not one just related to the mms protocol.

Cheers
linarchAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
linarchAuthor Commented:
Thanks, I used "network.protocol-handler.expose.mms" "false", clicked an mms link, and it popped up ith a box allowing me to choose a program. I had some trouble initially though because I was testing it by typing mms://test into the address bar instead of clicking a link, which resulted in the dreaded "not associated" message as usual. Once you have it associated though, after clicking an mms link and choosing the program, the address bar works as well. Also I figured out another possibly easier method by double clicking the "expose-all" setting to set it to false, clicking an mms link, and then double clicking "expose all" again to set it back to true.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.