Sluggish Gameplay Despite Good Hardware

Hello,
 I am having trouble playing Assassin's Creed 2 for PC. The game play is sluggish and choppy when using higher resolutions despite having the hardware to handle it. I have tried the game on 2 boxes thus far:

Sony Vaio VGN F111FX
1.7GHz Core i7 quad
4GB DDR3
NVIDIA GeForce 310 with CUDA

HP Elite
2.66 GHz AMD Phenom X4 quad
8GB DDR2
NVIDIA GeFORCE 9500GS

Both of these machines are more than sufficient to play this game but here is the problem:
When I play the game using higher resolutions it is choppy and sluggish. As I gradually lower the resolutions the game gets faster and better. By the time I get to a point where it is playing like it should I have lowered my nice 1080P resolution to something like 800x600. I don't have this problem with any other games on either of these systems. Dead Space, Bioshock, Empire at War, all work fine. I can't figure this one out. I need some help.
LVL 1
BoxunloXAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

☠ MASQ ☠Commented:
Do you have it patched to v1.01?
Which operating system are you using?
0
BoxunloXAuthor Commented:
Both machines are Win 7 and the onle patches that have been applied to the game are what was automatically installed during the install.
0
JeffroiscoolCommented:
Have you tried updating to the latest video card driver. I would say the 9500GS and 310 are a little slow. The videocard is a major bottleneck on your processor at the moment. You might want to try borrowing a better videocard and try it with that.
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

BoxunloXAuthor Commented:
I would agree with you if it were not for the fact that both machines handled COD Modern Warfare / Dead Space / Empire Total War / and BIOSHOCK with absoutely no problems. I think the problem lies with the game or a patch for the game or something of that nature.
0
TargetedLLCCommented:
In your shoes I would try the two following steps:
1.) Update the game to the most recent version
2.) uninstall and reinstall your graphics drivers.

While I'm aware you're having an issue with JUST Assassins Creed 2, and not BIoshock,CoD, etc, sometimes a conflict with a newer game and an older driver may appear in one game, and not another; Particularly a known resource hog like Assassins Creed 2.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BoxunloXAuthor Commented:
I haven't tried to implement the solution yet but this seems to be the most viable. Thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Computer Games

From novice to tech pro — start learning today.