Cisco 3750 using LACP to connect to a Celara NX4 NAS

I currently have a 3750 that I want to use in the dmz to connect a nas to a SQL server. If I set LACP on ports 3-12 in teamed ports such as 3-4 5-6 7-8 9-10  11,12. When I mhave this setup in VLAN 1 everything works when I move the  port 7-12 into Vlan 99 I can ping the sql ports 11 and 12 and get a response but when I ping the NAS I get no response. This is due to the problam that 7-8 are the nas and they administartivle diable as soon as I move them to VLAN 99 if I move all of the ports back to VLAN 1 everything starts to work again. Any thoughts on this would help greatly.
PatrickJmorrowAsked:
Who is Participating?
 
lrmooreConnect With a Mentor Commented:
Can you post your switch config?
Are you putting the port-channel into vlan 99 or just the interfaces?
0
 
PatrickJmorrowAuthor Commented:
I am putting the just the interfaces I will post  the config.
0
 
PatrickJmorrowAuthor Commented:
Below is the current config on the switch.

COM_123#show run
Building configuration...

Current configuration : 3146 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
!
hostname COM_123
!

!
no aaa new-model
clock timezone UTC -7
clock summer-time UTC recurring
switch 1 provision ws-c3750g-24ts-1u
system mtu routing 1500
ip subnet-zero
ip routing
!
!
!
!
no file verify auto
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Port-channel1
 switchport mode access
!
interface Port-channel2
 switchport mode access
!
interface Port-channel3
 switchport mode access
!
interface Port-channel4
 switchport mode access
!
interface GigabitEthernet1/0/1
 description NASmgt
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
 description NAScifsdmA1
 switchport mode access
 channel-group 1 mode active
!
interface GigabitEthernet1/0/4
 description NAScifsdmA2
 switchport mode access
 channel-group 1 mode active
!
interface GigabitEthernet1/0/5
 description NAScifsdmB1
 switchport mode access
 channel-group 2 mode active
!
interface GigabitEthernet1/0/6
 description NAScifsdmB2
 switchport mode access
 channel-group 2 mode active
!
interface GigabitEthernet1/0/7
 description IscsidmA1
 switchport access vlan 99
 switchport mode access
 channel-group 3 mode active
!
interface GigabitEthernet1/0/8
 description IscsismA2
 switchport access vlan 99
 switchport mode access
 channel-group 3 mode active
!
interface GigabitEthernet1/0/9
 description IscsidmB1
 switchport access vlan 99
 switchport mode access
 channel-group 4 mode active
!
interface GigabitEthernet1/0/10
 description IscsidmB2
 switchport access vlan 99
 switchport mode access
 channel-group 4 mode active
!
interface GigabitEthernet1/0/11
 description IscsiSQLA
 switchport access vlan 99
 switchport mode access
!
interface GigabitEthernet1/0/12
 description IscsiSQLB
 switchport access vlan 99
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
 description Uplink
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
 ip address 192.X.X.X 255.X.X.X
!
interface Vlan2
 no ip address
!
interface Vlan3
 no ip address
!
interface Vlan99
 ip address 192.X.X.X 255.X.X.X
!
ip default-gateway 192.X.X.X
ip classless
ip http server
!

!
control-plane
!
!
line con 0
line vty 0 4
 login
 length 0
line vty 5 15
 login
 length 0
!
end
0
SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

 
lrmooreCommented:
Try putting the port-channel into the vlan instaed of the individual ports
interface Port-channel4
 switchport mode access
 switch access vlan 99

interface GigabitEthernet1/0/9
 no switchport access vlan 99

If that doesn't work, remove the interfaces from the channel group, then remove the port-channel, then setup the interfaces in vlan 99, then re-add the channel group command to re-create the port-channel after the interfaces are already in the vlan.
0
 
PatrickJmorrowAuthor Commented:
lrmoore I did not even think of putting the Port channel in the VLAN  OF course it would disable as it would not know how to communicate. But waht is the reason for the no switch-port access Vlan 99 on port 9 or are you saying to remove it from all ports that would reside in the VLAN 99?
0
 
NetFixr-DaniConnect With a Mentor Commented:
Simply stated, the configuration of the port-channel must match that of the physical child interfaces.

The safest way to do this is to clear out all config on the child interfaces, and then apply to the port channel.  The switch will take care of propagating that.

For example, do this:

int ran gi1/0/7 - 10
  switchport access vlan 1
! that will set default configuration

int ran Po3 - 4
 switchport access vlan 99


... now go ahead and look at your config, e.g. "show run int gi1/0/7" and you'll see that vlan99 is configured.

BTW, if you were watching logs, you should have seen an error about "failed to bundle" due to vlan mis-match, or something like that.
0
All Courses

From novice to tech pro — start learning today.