[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3191
  • Last Modified:

How do I stop IE8 from blocking google translate

I am using the Google translate button on my web site. It works fine in Firefox, Safari, and of course Chrome but not in IE8. If i click on the bloodshot eye in the status bar it tells me that http://translate.google.com/... cookies are blocked. So I click on 'Settings" in the dialog box click on "Advanced" and select "Override Automatic Cookie Handling"  and "Accept First Party Cookies" and "Accept Third Party Cookies" and "Always Allow Session Cookies"; that doesn't fix it. I then clicked on "Sites" and entered the google.com domain and the "Allow" button; still no fix. Protected mode is also off. Can anyone tell me how to get this to work for IE8? Attached is the code for the Google translate button.
<div id="google_translate_element"></div>
<script>
function googleTranslateElementInit()
{
new google.translate.TranslateElement({pageLanguage: 'en'},'google_translate_element');
}
</script>
<script src="http://translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"></script>

Open in new window

0
Kibbage
Asked:
Kibbage
  • 15
  • 9
  • 7
  • +3
1 Solution
 
Mike ThomasConsultantCommented:
Try adding the site to yur trusted zones in IE8, if that works then it's one of the many other security settings in IE blocking something.

0
 
KibbageAuthor Commented:
Nope, that didn't fix it. If you want to see the problem go to www.teeso.com and in the center pf the page above the word "Welcome" you are supposed to see the Google Translate button.
0
 
burrcmCommented:
Are you still having the issue? I have IE8 on Vista and Win7. The button shows correctly at www.teeso.com without any adjustments.

Chris B
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
Darr247Commented:
I was going to suggest restoring the formatting the page gives when you generate it ('code' box), but when I went to your site it appears to be working in my IE8 (screengrab attached).

*Not* in Compatibility Mode, for what it's worth.
<div id="google_translate_element"></div><script>
function googleTranslateElementInit() {
  new google.translate.TranslateElement({
    pageLanguage: 'en'
  }, 'google_translate_element');
}
</script>

Open in new window

teeso-com.png
0
 
KibbageAuthor Commented:
Yes, i still have the problem. I am impressed that it works for you because you are the first person to get it to work. All of my IE8 clients that i have asked don't see it as well as myself. I will ask more of my clients.
0
 
KibbageAuthor Commented:
What I see in the image is use of the Google translate button on the tool bar and not the button on my page.
Doc1.docx
0
 
burrcmCommented:
This is mine...

Chris B
teeso.jpg
0
 
burrcmCommented:
Fired up an XP box with IE8, fine. It even works on a Win ME box with IE5!! Yes I really have one.

Chris B
0
 
Darr247Commented:
> What I see in the image is use of the Google translate button
> on the tool bar and not the button on my page.

I don't get a button on the 'page' I guess...  when I first get there mine looks like the screen grab that burrcm posted.

As soon as I select a language from the page's single-column picklist it translates to whatever language I choose, even when I go to translate.google.com and turn off AutoTranslate at the bottom of the page... i.e. I don't need to click a button.

After I use the 'Show Original' button, that button changes to 'Translate', and the extra picklist appears on what you've referred to as the toolbar... when I use the down arrow in that toolbar's picklist the extra 5-column picklist is shown.

Are you saying when you select a language from the page's picklist in IE8 it does NOT translate?
0
 
KibbageAuthor Commented:
The problem with my IE8 and several of my clients IE8 browsers is that nothing appears between the logo and the word welcome. As I said originally it works with all other browsers I tried just not IE8. Since a lot of my clients use IE8 I need to fix this. I am glad to see that it works for some people because that means it must be a setting on my (and my clients) computer that is causing this failure. Now if I could just figure out what setting.
0
 
Darr247Commented:
Most likely "Active Scripting" is completely disabled on the machines not displaying the scripted menu. It's enabled with the default 'Medium-High Security'  but disabled if the setting is changed to High Security.

See attached. That's in Internet Options on the Security tab.

If that setting is locked down via policy the users probably cannot change it.
ActiveScripting-Enable.png
0
 
steveoskhCommented:
I was also able to see and change the language without problem on both my machines running IE8 (Visat and XP).
Looking at internet options I am set for the default Medium-High for the internet zone.   If I change the setting to High and then re-load the page, I no longer see the translate function.  Change setting back and it returns.
One of the security settings.
NOTE: Even when the language bar is shown my browser is still blocking the google cookie.  This IS NOT a cookies issue.
In the scripting section  Set  "Active Scripting" to Enabled
Once this is done the translate function shows even if my security setting is set to High.
0
 
steveoskhCommented:
Darr247, sorry, loaded the question and then did not get back to it for a few hours.  Should have refreshed before responding.
0
 
KibbageAuthor Commented:
Active Scripting is enabled for all zones excepted the restricted zone. Just to be sure I enabled it for the restricted zone too but that didn't help.
0
 
KibbageAuthor Commented:
FWIW If I view source the code is there so it's not being removed by some security option.
0
 
steveoskhCommented:
Set the security level to medium-high with default settings.   If it still does not work, set to medium.
0
 
KibbageAuthor Commented:
Setting Internet Security to medium and restarting the browser did not fix the problem.
0
 
steveoskhCommented:
OK something is not right here.  It does not work for you or any of your clients, however, the 4 people responding to your post, it works fine.
What version of Java script is I.E. 8 using?
0
 
KibbageAuthor Commented:
How do I find that out?
0
 
steveoskhCommented:
Tools  - Manage Add-ins  
0
 
KibbageAuthor Commented:
Guys, I have an update! I and the four clients I have been working with (they all work at the same place) are all using the IE8 64bit version. If I use the IE8 32bit version it works!
0
 
KibbageAuthor Commented:
Have any of you used the 64bit version?
0
 
steveoskhCommented:
MS does not install Java with windows any longer.  You need to download java and install it on these PC's
0
 
steveoskhCommented:
http://www.javatester.org/enabled.html
Tests to see if Java installed and running.
0
 
steveoskhCommented:
0
 
KibbageAuthor Commented:
IE8 64bit now supports Java however the Google Translate pull down list (I should not have said button) still does not appear on my web page.
0
 
Darr247Commented:
It's not IE8 64-bit's fault, per se.  See attached.
That's with the default Medium-high security, and Enable Protected Mode is checked, too.
teeso-com-IE64bit.png
0
 
billmercerCommented:
Remember to go back and reset your security settings to safe ones, allowing active scripting on all web sites is unsafe.

This is not a Java issue, the site is not using Java, just Javascript, which does not depend on a JVM.
"The problem with my IE8 and several of my clients IE8 browsers is that nothing appears between the logo and the word welcome."

This sounds very much like a javascript issue of some sort. Possibly a compatibility issue between your version of IE and Google's API, or maybe some sort of security software on your computers. Some third-party security software will interfere with javascript, so make sure you have either disabled it or whitelisted your site while testing this.

Try using the developer tools option in IE8 (hit F12) to debug your page. If there's some sort of javascript error that you're not seeing, you may be able to find it that way.

One thing I noticed is that the Google translate snippet the script tags don't specify the language.
Probably not relevant, but you might want to try changing those to  <script type="text/javascript"> just for yucks.


0
 
KibbageAuthor Commented:
I noticed that also and added the type parameter in the off chance that was the problem but not joy. I think it's time I deleted and reinstalled IE8.
0
 
Darr247Commented:
> Remember to go back and reset your security settings to safe ones,
> allowing active scripting on all web sites is unsafe.

Tell it to microsoft... that's the default setting (Medium-high security) which has it enabled.

I typically use Firefox in Fedora 12. I rebooted to windows to make the screen shots just to show what it looks like from this end in IE8.
0
 
KibbageAuthor Commented:
Okay guys, I give up. I removed IE8, that took me back to IE7, installed 64bit IE8 and applied maintenance. I'm tired of this.I will just tell my clients that they will have to change browsers.
0
 
billmercerCommented:
>Tell it to microsoft... that's the default setting (Medium-high security) which has it enabled.

Not true. The OP said...
"Active Scripting is enabled for all zones excepted the restricted zone. Just to be sure I enabled it for the restricted zone too but that didn't help."

I was reminding him to return it to a safe setting.

0
 
KibbageAuthor Commented:
We can close this as I don't think there is a solution based on my funky computer. Thanks everyone!
0
 
Darr247Commented:
You can select your own message (http:#30442662) as the solution and after a few days (without Objections) it will close by itself.

The underlying problem must be some type of filtering software like ZoneAlarm, Symantec 360, et al, that stops scripts before they even get to the browser.
0
 
steveoskhCommented:
Your clients can also install Google toolbar and it will provide translation services for any website.  No special coding needed on your part.
0
 
KibbageAuthor Commented:
yes, except we are talking about potentially 3,300 people.
0
 
Darr247Commented:
Just a heads up for anyone that finds this thread while reasearching a similar problem... see message http:#30442662 for the ultimate course of action taken, not the message that will (without objection) get the green 'solution' title bar on 04/20/2010.
0

Featured Post

The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

  • 15
  • 9
  • 7
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now