Firefox is very slow as one user with remote display

Computer 1: ubuntu, running Firefox 3.5.8
Computer 2: Running Windows, with cygwin, and cygwin/X.

I ssh from computer2 to computer1, run "export DISPLAY=computer2:0.0", then start firefox.  First, I will get a window on computer2 that says "An error occurred while loading or saving configuration information for firefox.  Some of your configuration settings may not work properly."  It has a "Details" button, and an "OK" button - but does not respond to clicks of either.  It also does not respond to clicking the "X" on this window.  Eventually, the main Firefox window will come up, but it is extremely slow.  One up, everything is extremely slow - it'll take 30 seconds from when I click the "down" arrow on the scrollbar before it even starts to scroll.  If I use the -X option of ssh, there is no change.

If I am on computer1, with display set to computer1, everything works normal.

If I am on computer1, with display set to computer2, everything works normal (firefox displays on computer2, and works at normal speed).

If I am on computer1, ssh to computer2, set display to ":0.0", everything works as normal (firefox displays on computer1, and works at normal speed).

If I am on computer1, ssh to computer2, su to a different user, set display to "computer2:0.0", everything works as normal (firefox displays on compute2, and works at normal speed).

LVL 39
Adam314Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Adam314Author Commented:
Also, "firefox -safe-mode" makes no difference.
0
omanandgiriCommented:
restart and again try firefox safe mode.
0
acl-puzzCommented:
Hi

some days i was having this problem when i was wanting to connect to my VPS my VPS and my pc bandwidth was great! but still i was having issue then i used an free solution its ssh based pretty secure and as easy to use as windows remote desktop

Its free NX from http://www.nomachine.com/select-package.php?os=linux&id=1 works great from linux client and also from windows client.

if you need further help please tell.

Cheers
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

Adam314Author Commented:
omanandgiri>> I've tried this many times - it is always the same.

acl-puzz>>I've see NX, and it looks interesting.  But, for now, I want to know what the problem is with using standard X.

0
Duncan RoeSoftware DeveloperCommented:
I woner if it's to do with X authority? On a system that works, try the env command below (the output on my system is atypical).
When sshing from the problem system, make sure XAUTHORITY is in your environment. Make sure too that you have read access to the nominated file.
18:41:44$ env|grep XAUTH
XAUTHORITY=/home/dunc/.Xauthority

Open in new window

0
Adam314Author Commented:
duncan_roe>> On computer1, XAUTHORITY was set, but when I logged in from computer2 with ssh, it wasn't.  I set it to the same, and this didn't change anything.  It turned out that the unresponsive error dialog I mentioned originally was not completely unresponsive - just very slow.  Going back and forth between the computers, it had a chance to respond (took it several minutes!).  Once this dialog showed the detailed error message, I was able to search on that.  The .dbus directory in my home directory was owned by root, not by me.  I changed this to be owned by me, and everything seems to work.  Even without XAUTHORITY set, it works fine.

Not sure why this directory was owned by root, or why that had the effect it did (as everything worked normally when run locally).  Any ideas on this?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Duncan RoeSoftware DeveloperCommented:
I don't have a .dbus so, no I have no idea.
0
taym78Commented:
I agree with acl-puzz.  NX is great.  There is nothing out there that is faster for doing remote connections.   NX on Ubuntu (32bit).  Just download the three packages and install them.  Client runs on anything.  It will run circles around a straight X session even with compression enabled.  Straight Xsessions are not known for their speed. Also cygwin though a good tool for windows is also a bottleneck for speed.
Also if you are planning on running a browser over a slower remote connection (like the internet)  Opera browser is much faster than Firefox.  Don't get me wrong, I love Firefox and prefer it to anything except in this case were Opera is much faster.
0
Adam314Author Commented:
I've installed the NX on ubuntu.  This was pretty easy, as their is plenty of documentation.

I couldn't find much for how to install/configure it on cygwin though.  Any suggestions?
0
acl-puzzCommented:
y u need it on cygwin  just curious to know?  :)

0
Adam314Author Commented:
I guess I don't.  I installed the windows client from the nomachine.com website.  This was easy to set up, and seems to be working.  This starts an entire gnome (or whatever window manager I choose) session.  How I normally run is I ssh to the server, export DISPLAY, and run whatever program I need.  I have cygwin/X setup to not display the root window, so each program/window I run gets it's own top-level window on the client machine.  If possible, I'd like to have NX work this way.  Is this possible?
0
acl-puzzCommented:
i havnt tested this thing see help option in nxserver command you may find it there or just type nx and press tab key to see all nx commands like nxserver nxagent nxnode etc  :)
0
Adam314Author Commented:
Thank you all for your help.
0
Duncan RoeSoftware DeveloperCommented:
Hey Adam314
It's great that you fixed your problem, but can you please post what you did?
0
Adam314Author Commented:
I mentioned this in post 29026011, but here it is again:
The .dbus directory in my home directory was owned by root, not by me.  I changed this to be owned by me, and everything seems to work.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.