SonicWall Pro 2040 slow bandwidth

Hello we are running a Sonicwall Pro 2040 with the 4.2.0.1-12 enhanced firmware. We recently upgraded to cable modem internet service from a 1.5 T1. If I hook a laptop with a static ip directly to the cable modem, I'm getting about 30 mps down and about 8 mbps up. Inside my firewall I'm getting about 8 mbps up and 8 mbps down no matter which machine I run speedtest.net.

I have experimented with disabling the VPN tunnels, content filtering, AV, and IPS on the Sonicwall and that doesn't seem to make a difference. Also disconnected the servers from the network and that didn't help. The connections monitor on the SonicWall didn't seem to look very remarkable either. The only think I've noticed to make a difference is when I reboot the Sonicwall, for about the first two minutes after it reboots, I'm getting 22 to 25 mbps down and 8 up. Shortly thereafter, its back to the 8/8 speed. Any ideads ?    Thanks!
crdixonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

linrafCommented:
If this is in a commercial building and the hand off is coming from a switch in the building before getting to you, you may need to have a programmable switch that you can lock into 100m Full duplex.  (or possibly try locking the sonicwall waan port to this, but I have had problems using the sonicwall as the lock point)

Otherwise, have you connected just a single machine (as opposed to your whole network). to the sonicwall and gotten the same results?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
crdixonAuthor Commented:
I tried the manually setting 100 full duplex but that didn't make a difference. Haven't tried bypassing the rest of the network behind the SonicWall. That will have to wait until after hours. All my switches are Cisco Catalysts. The hand off is directly from the ISP via a cable modem that patches into the WAN port of the SonicWall
0
crdixonAuthor Commented:
I yanked the primary LAN interface and ran a laptop off the second LAN interface, still got about 8 up and down. Just for kicks I put a linksys switch in between the cable modem and the SonicWall. This was so I had anther device doing the handshaking with the cable modem but that didn't have any beneficial effect. A laptop into the Linksys switch configured with a public IP inbetween the cable modem and the SonicWall had 23 down and 8 up. Talked to SonicWall support for several hours, as well as the cable company, and got nowhere other than to confirm packets were not being dropped and we monkeyed with the MTU settings. Per the SonicWall specs, the lowest throughput on this 2040 should be 25mbps. Funny when I got support with the ISP, they asked if I had a Sonicwall before I even told them. I'm thinking SonicWall needs to send me a new box. Sure seems like I'm hitting a 10 mbps limit somewhere.
0
The Lifecycle Approach to Managing Security Policy

Managing application connectivity and security policies can be achieved more effectively when following a framework that automates repeatable processes and ensures that the right activities are performed in the right order.

crdixonAuthor Commented:
also upgraded firmware to 4.2.1.0-20e and that didn't help either.
0
basbasbasCommented:
Yesterday I solved this exact same problem by putting a simple switch between the Sonicwall WAN port and the DSL modem. You could also use a managed switch and VLAN two ports.

Set the LAN port of the Sonicwall to automatic and maximum speed, set the WAN Port to 10 Mbps full duplex MDIX and make sure (if possible) that the ports on the manged switch are set the same way. Perhaps you need to try diffrent settings and diffrent speeds.

The customer has three bundled 2Mb/2Mb sDSl lines, at first we had a speed of 600 Kb down and 15 Kb up through the Sonicwall, after adding the switch and fiddling the interface settings we ended up with a speed of 1 Mb up
!
0
linrafCommented:
As the conecting speed at their location is more than 10Mbps, I had suggested they use 100Mbps Full Duplex.
0
crdixonAuthor Commented:
I tried all LAN & WAN settings between auto-negotiation, 100 full, etc but no differnece. Also put a linksys switch in betwen the cable modem and the SonicWall - no change. The cable modem is set to auto per the ISP and can't be changed. If I plug a laptop directly into the cable modem or behind the Linksys, I'm getting 30 mpbs down. I sent my config file to SonicWall support and they can't get above 8 down either. The SonicWall documentation says it should get 25mbps even with IPS service on. Still scratching my head but I have sure seen a lot of similar complaints in various newsgroup with SonicWall's choking the bandwidth.
0
basbasbasCommented:
Try this:

Put the Linksys in between the Sonicwall and the cable modem, set both ports on the Linksys to a fixed rate, 100 Mb Full for instance. If possible select cable type MDIX.

Configure the Sonicwall:
Under Network->Interface->LAN: Enable Auto-negotiate and Multicast
Under Network->Interface->WAN: Enable Auto-negotiate and Multicast, check 'Fragment non-vpn packets', uncheck 'Ignore ...',  use 1492 as MTU
Under Network->Switch Ports: Enable Auto-negotiate on all ports

These settings did the trick for me. (I've used a Linksys WRT54 for my initial tests and later on a 2-port VLAN of a managed LinkSYS switch)

I never tried it, but you could also try to VLAN (Portshield) two ports of the Sonicwall internal 4-port switch and use these two ports as an intermediate switch ;-)


0
crdixonAuthor Commented:
Basbasbas: Thanks for your reply, I tried the first two settings. The third, I don't have an option for Switch port under the Network tab on the SonicWall 2040. Only three interfaces are being used on it, LAN (X0), WAN (X1) cable modem, and there is a backup DSL circuit on X3.

I did utilize my laptop into the 2nd LAN to bypass the rest of the switches and servers but still had the same bandwidth.
0
linrafCommented:
crdixon:
I am not sure if you are realizing that it need to be a manged/programmable switch in between the modem and the sonicwall.
You have to lock the incoming port on the switch to 100Mbps full duplex.  
If you've done this, I am ready to blame the sonicwall also.
I have fully loaded TZ190's getting over 15Mbps throughput.
0
crdixonAuthor Commented:
Linraf, Thanks for the feedback. Unfortunately, I've already tried that too. The router/switch I was using was a Linksys RVO82 which does let you configure the link speed on a per port basis. I was only using the switched ports and did not use the Linksys as a router.
0
basbasbasCommented:
We have a TZ190, with an internal switch. Don't know bout the 2040. But setting the speed on these ports other than 100 MBps/Full or Auto is disasterous. Try and find if your Sonicwall has configurable switchports.

Question: what does the Sonicwall say about the speed in Status for both interfaces?

Other things you could try:

- Use different combinations of speed and duplex
- Use a crosscable between the modem and the WAN-port
- Use a crosscable between your network and the LAN-port
- Try a realy old firmware-version (somewhere I read this solved someone problem)
- Look at counters; are there much errors?
- Do a packetcapture on the Sonicwall and look for unknown or strange packets
- Try overriding the mac-adress, both WAN and LAN (e.g. 00:00:BA:BE:01 and 00:00:BA:BE:02)
- Disable all antivirus, contentfiltering and other stuff

Good luck!


0
crdixonAuthor Commented:
The status for the switch port always says its getting 100 full duples whether or not it is set that way or on autonegotiate. Sonicwall had me do a pacjet capture and there were zero errors. I have disabled the security features and that made no difference. Haven't tried tha mac address thing. I also saw that post somewhere where an old firmware version resolved a problem for another SonicWall'er. I really hate that idea as I'm sure that will be a step backwards security-wise.

At this point , since the SonicWall is under a service contract, I think I'm going to put this back on them and demand they send me something that meets spec because this shouldn't be this complicated. When I sent my config file to SonicWall they had the same performace issues.
0
basbasbasCommented:
You could try setting the speeds to 100 Mb half duplex. But I think the Sonicwall has a problem.

Good luck and please keep us informed if Sonicwall has a solution!
0
explorer1979Commented:
ASk SonicWALL replace the PRO 2040 to NSA2400 to you.

IT will fix all your performance case.
0
crdixonAuthor Commented:
Just a followup. I had replaced the Pro 2040 with an NSA 240 and did not really see any bandwidth gain. The motorola cable modem was replaced with a Cisco cable modem and that seemed to make a big difference. Odd that the motorola performed ok when directoly conntected to a laptop, however.

I guess the Motorola didn't like talking fast to the SonicWall.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software Firewalls

From novice to tech pro — start learning today.