Belkin F5D7050 Wireless G USB Network Adapter will not work properly

I have a XP laptop that had a USB network card that worked properly yesterday, but now the card does not stay on for more than a few seconds.  I have uninstalled and reinstalled to no avail.  What should I do?
mounty95Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ChickensaurCommented:
Have you tried putting other USB devices into the port to rule out the port?  Have you installed the card on another laptop as a test as well?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mounty95Author Commented:
It looks like it may be the USB port so I am going to start with a rebuild of the OS to see if something has corrupted the USB port and then go from there.
0
mounty95Author Commented:
It turns out that it was an issue with the USB port driver.  A reinstall fixed the issue.
0
mounty95Author Commented:
Thanks for pointing out a method for troubleshooting.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Hardware-Other

From novice to tech pro — start learning today.