SAS Tape drive in Vmware Esx 4.0

Hi Guys ,

I'm having issues connecting to a SAS tape drive through a VM after upgrading to  ESX 4.0 from 3.5 host . Tape drive is connected through LSI 1068E & it’s in vmware compatibility list .

As explained in the below article . I have assigned The IBM tape drive to  “virtual device node” to SCSI (1:0) ,
http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1016407 

Please find the controller & tape drive details below ,

# cat /proc/scsi/scsi

Host: scsi5 Channel: 00 Id: 00 Lun: 00
  Vendor: IBM      Model: ULT3580-HH3      Rev: 85P2

esxcfg-mpath -l for tape drive

sas.500605b000d5aab0-sas.500507631243eded-naa.500507631203eded
   Runtime Name: vmhba1:C0:T0:L0
   Device: naa.500507631203eded
   Device Display Name: IBM Serial Attached SCSI Tape (naa.500507631203eded)
   Adapter: vmhba1 Channel: 0 Target: 0 LUN: 0
   Adapter Identifier: sas.500605b000d5aab0
   Target Identifier: sas.500507631243eded
   Plugin: NMP
   State: active
   Transport: sas
   Adapter Transport Details: 500605b000d5aab0
   Target Transport Details: 500507631243eded

I'm using symantec backup exec 12.0 & Backup fails with "e000fe1f - The device cannot be found."

regards,
TR
thecavalryAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

DavidPresidentCommented:
Are you saying it worked fine under 3.5?
In any event, what is the physical device name you are assigning, and have you tested it outside of backup exec?  I.e. if dev is /dev/rmt/0mn  then use dd to backup directly to tape to see if dd has a problem.   If dd fails, then you can eliminate backup exec.  this isn't a cure, but at least you know that the application software is not part of this problem.
0
thecavalryAuthor Commented:
Hi dlethe ,

Thanks for the swift response . Yes it was working with 3.5
I have attached screenshots to show how tape device is attached to the VM ,

I'm not that familiar with ESX CLI , Can you please give more information how to use DD . Like how to fid the tape device name & example script for backup .

Thanks & Regards,
TR
rr01.jpg
rr02.jpg
0
serrato01Commented:
we're having the exact same issue with one client. we were able to come up with a solution on some servers with newer processors though. what kind of cpu do you have on the host?
0
thecavalryAuthor Commented:
Hi serrato01 ,

Sorry for the late reply . The processor is Intel Xeon E5405 2GHZ QC x 2 .
0
serrato01Commented:
with the newer xeon e55xx series you can use vmdirectpath. unfortunately with the e54xx series that is not available. i applied some update and patches from vmware to the host and it seemed to help as we were able to get two sucessfull backups in a row but then it failed friday night. we use CA's ArcServe backup.  i was able to go in on saturday morning and restart the tape engine service and then successfully run a backup. all of the research i'm finding is saying this is not going to work. i'm really not sure what the fix is for this yet or if there is one. right now i'm looking into getting an enclosure for the drive so we can attach it to a physical box as it appears using a vm is not going to work. just out of curiosity what kind of server do you have? i'm using a dell 2900 with an ibm lto4 tape drive on a lsi 1068 controller.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.