ASP web site migration from IIS6 to IIS7 Internal error 500

Note: I posted that on Technet and no one could answer so I am posting it here.

Hi,

I have a ASP web site linked to a MySQL database that works very well under
IIS 6.0 but as soon as I try to transfer it to IIS 7.0, I get an Internal
error 500 page.

I worked with a web developer friend of mine and together we validated that
the MySQL database is responding correctly, that all the paths are OK and as
for myself, I made sure that standard IIS permissions were applied to the web
folders. Mainly, the error occurs as soon as the ASP code tries to read an
image from a sub-folder in the web site (such as
websiterootfolder\images\suppliers\image.jpg).

Despite all of our efforts, the site still fails to load because it stops when reading the images. However, my
programmer told me about a value that he had changed from "none" to "scripts
only" in IIS 6.0 that was interfering with some of his web sites.

It was in the "Home Directory" tab of a particular web site properties in
IIS 6.0.

The description is as follows:

Application name: website.com application
Starting point: <website.com>
Execute permissions: Scripts only (changed from None)
Application pool: Shared_ASPNET2.0_AppPool

Just making this change from None to Scripts only fixed the problem and he
demonstrated it to me with a non-production web site with similar code in IIS
6.0. However, we are not able to locate this menu/value/field within IIS 7.0.

I am not a web developer myself but since the web site is working just fine
under IIS 6.0, I must assume that this is some kind of permission issue since
we validated that the ASP code itself is not the cause (he's the programmer,
not me..). I tried every Windows permissions as possible (even admin rights
to all web folders) without any luck. I also checked that my server has all
the appropriate components installed although some of them are not enabled:

- Custom logging, ODBC logging, Client Certification mapping authentication,
IIS client certificate mapping authentication, URL authorization and IIS
Management Scripts and tools.

Does anyone has a clue how to make that web site work under IIS 7.0?

Thanks.

Benji.
LVL 1
benjilafouineAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

willk400Commented:
Have you tried turning off frendily HTTP errors in IE and see if it gives a more specfic error? This can be done in the Advanced tab in Internet Options. I had a similer problem happen to me as well and it ended up being a step I missed which was in command prompt:
regsvr32 <path & filename of dll>

I figured this out once I turned off friendly errors and found a dll that was causing the issue.
0
benjilafouineAuthor Commented:
No sure I am following your suggection. Where do I chenge this parameter? In the web site properties (somewhere) or for the whol IIS server? I am not that familiar with IIs 7.0.

Thanks.
0
benjilafouineAuthor Commented:
Ahh. You mean in the web browser. Not at the IIS level... Trying...
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

benjilafouineAuthor Commented:
No difference. Same error message. In fact as I pointed out in my original message, it really seems to be a security/permission error because we tried returning the path of the pictures by changing the code itself and it is really returning the appropriate value. However for some reason, it cannot read the image (which is there).

What I don't understand is that this web site is working live on IIS6 as I write this message. I guess I have to search for the differences in the default parameters.

Benji
0
benjilafouineAuthor Commented:
More info on the error 500: There is a problem with the resource you are looking for, and it cannot be displayed.

But the "resource" is there and all the paths are correct.
0
Wayne BarronAuthor, Web DeveloperCommented:
A few things for you to check on.

Installing ASP Classic on IIS7

Enabling ASP Classic error messages in IIS7 and Windows Web Server

Have a look at these and run through them and see what happens.

Carrzkiss

0
golfDoctorCommented:
You need to set iis to show you the error message, in addition to your browser:
http://serverfault.com/questions/61038/make-iis7-show-error-and-stop-showing-505-page
0
benjilafouineAuthor Commented:
Here is what I did: I started by uninstalling ASP and reinstalling it (whil it was uninstalled, the error 500 became and error 404, probably because the web site requires ASP).

Second thing, I disabled the "show friendly error messages" feature in IE 8.0 and set the "send errors to browser" to true.

However I keep getting the message: 500 - Internal server error.
There is a problem with the resource you are looking for, and it cannot be displayed.

I didn't run the script (yet) to enable IIS 6.0 errors. Why would this site work perfectly in IIS6 and not in IIS7 (just ported to IIS7 without any modifications).

My programmer did some testing and found exactly where the error occurred:

path = "images/logos_suppliers/"&image
            if (fichobj.FileExists(server.MapPath(path)))=true then...

He added a test command that returns the value of the mappath command and the value correctly pointed to the images folders below the root of the web site. So we know where the error is, but we don't know why the returned value will not work (just as if there were permissions issues on sub folders).

I will keep searching. Worse case, I will throw the error in MS's backyard (using my Technet subscription). I am so tired of searching.

Benji.
0
jaguarmediaCommented:
Hello,
The problem is when he use the object (fichobj).
fichobj is a FileSystemObject.
Set fichobj = CreateObject("Scripting.FileSystemObject")

Regards,
0
benjilafouineAuthor Commented:
I found the solution:

the user iusr has to be added in the security attributes of the web site with read/write rights. Once that is done, no more issues.

By the way, my programmer found the answer on this site:

http://www.experts-exchange.com/Web_Development/Web_Languages-Standards/ASP/Q_23379390.html

Who gets the points?

Benji.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ASP

From novice to tech pro — start learning today.