Redhat Enterprise 5.4 Clock/Time issue when running as a VM under MS Hyper-V Server 2008 R2

We have a Hyper0V Server 2K8 R2.  We created a virtual machine and loaded Redhat Enterprise 5.4.   It seems like the VM will not keep proper time.   We have set up a cron job that will update the clock every 15 minutes or so, but that obviously is not the solution.   Does any one have any fixes for this issue?
BladesAwayAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Kerem ERSOYPresidentCommented:
Hi,

This is a known problem with some Virtual systems especilly guests under Hyper-V. A clock chip can not be emulated for obvious reasons (it is by definition a piece of hardware there's no point in emulating it since the emulation wount be as acurate as the hardware). You'd better start the ntpd service over the RedHAT Server.

To enable the ntpd over redhat you'd issue these commands:

chkconfig --list ntpd

(to make sure that ntpd is installd)
If not pelase install it first :

yum install ntp

then you'd turn on the service with this command:

chkconfig ntpd on

and you'd start it with this command (Since the above comand will only enable it to be run next time the ssytem reboots)

service ntpd on


This should be enough and your system should stay up-to-date afterwards.

You can check the accuracy of your clock using the command

ntpq and issuing
>lop

Or

ntpdc
> sysinfo

Cheers,
K.

comand
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Kerem ERSOYPresidentCommented:
Oops sorry this command for starting the ntpd should read:
service ntpd start

not

service ntpd on

Cheers,
K.
0
JordanH155Commented:
You can try appending "clock=pit" to the end of the kernel line in grub.  

There is actually a Microsoft KB article here: http://support.microsoft.com/kb/918461  with instructions on how to add it for grub and lilo.

0
Kerem ERSOYPresidentCommented:
I'll have another suggestion that I've myself applied for some time now. Though you can synchronize using the pit clock it is also a hardware emulation clock which would lead some errors now and then. The only thing it fixes is to prevent the clock gain 50 seconds in 1 minute !! Apart from that it is not an accurate time.

My suggestion is to apply the changes to your hyper-v system and convert it to an NTP time source then use NTP and synchronize time with this system . This has another advantage that all your systems will have a synchronized clock and if you use, you'll have consistent logs all over your network.

Here's the article:  http://support.microsoft.com/kb/816042

Cheers,
K.
0
BladesAwayAuthor Commented:
I am working the suggestions.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.