SIEBEL remote application in readonly mode

Hi all,

SIEBEL remote application opening in read-only mode. Could you please provide me steps in avoiding this problem.

Thanks & Regards,
Sarat.
saratcmAsked:
Who is Participating?
 
Paul_Harris_FusionConnect With a Mentor Commented:
Apologies if the following is blindingly obvious and you have already checked it.

The only normal mechanism (that I am aware of) that puts a remote client into a readonly state is Siebel Anywhere.   However, this only occurs when  a user declines to upgrade one or more components to the versions required by the siebel anywhere component. Is there any possibility that Siebel Anywhere is doing this?     You could try changing the cfg file entry
ComponentName            = Siebel ePharma Client
to
ComponentName            = xxxxxxSiebel ePharma Client

and restarting.

Other than that,  have you checked the table permissions in the local database for the user your are connecting as?    Have you checked the file permissions on the dbf file itself?



0
 
BigSchmuhCommented:
If you have normal access using a Web client, then your .dbf local file may have a "read only" NTFS attribute
0
 
saratcmAuthor Commented:
Hi,

what do you mean by normal access? And what kind of accesses can we have?

Thanks & Regards,
Sarat
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
BigSchmuhCommented:
You looks like expecting NOT to be in "read only"...so I assumed you tried accessing SIEBEL from a Web Client and had no problem to issue read-write operations on it.

A SIEBEL remote application is a unwired app that runs on its local db and synchronized from time 2 time to the SIEBEL server (The synchronization process should be very fast)
0
 
saratcmAuthor Commented:
Hi,

Iam aware of the SIEBEL remote application and the processes of synchronization to server for the data to be transfered from local to server and vice-versa.

But the problem here out is that the local siebel application is opening in readonly mode and hence i was not able to make any changes in the local application.

Hence, I would like to confirm if there are any settings that need to be made in the .cfg file or somewhere else?

Thanks & Regards,
Sarat
0
 
BigSchmuhCommented:
There are NO cfg parameters that I am aware of that would lead to a "read only" behaviour...except may be in the ConnectString of your [Local] section (or the one used for the Remote app you are launching)

Can you post here:
-The Shortcut command line of your remote app
-The [local] section parameters for this app
0
 
saratcmAuthor Commented:
Hi,

Please find the details below

Shortcut:
C:\Siebel\7.7\WEBCLI~1\BIN\siebel.exe /c C:\Siebel\7.7\WEBCLI~1\bin\END\epharma.cfg

Local Section of cfg:


[Local]
ConnectString            = C:\Siebel\7.7\WEBCLI~1\local\sse_data.dbf  -q -m -x NONE -gp 4096 -c25p -ch35p
TableOwner               = SIEBEL
DockedDBFilename         = CHANGE_ME
DLL                      = SSCDW8.DLL
SqlStyle                 = Watcom
MaxCachedCursors         = 32
MaxCachedDataSets        = 32
ReverseFillThreshold     = 100
CaseInsensitive          = FALSE
InsensitivityFactor      = 2
DockTxnsPerCommit        = 500
DockConnString           = emasfadbo51
ChartServer              = localhost:8001
ChartImageFormat         = png
AutoStopDB               = FALSE
EnterpriseServer         = ENT1
RequestServerName        =
UseCachedExternalContent = TRUE
DSHashUserPwd             = True
DSHashAlgorithm          = RSASHA1
0
 
BigSchmuhCommented:
The ConnectString does not has a "-r" read only option to explain your problem :-(

Please try the exact same Shortcut to connect to the "Server" datasource and confirm that you can update some "Server" data...otherwise this is only a matter of using a "read only mode" SRF
0
 
saratcmAuthor Commented:
Hi,

 can you please provide me the details how we can see if the SRF is opening in readonly or not? If yes, how can we change the mode of th srf?

Thanks & Regards,
Sarat.
0
 
saratcmAuthor Commented:
Hi Paul Hariis,

Thanks a lot.That worked!! I commented out the component name parameter and it worked.

Thanks & Regards,
Sarat
0
 
Paul_Harris_FusionCommented:
I'm glad it worked.

However,  I would recommend you view it as a diagnostic aid rather than a long-term fix.

The underlying cause is that your local set of components is out-of-date according to the Siebel Anywhere configuration.    Using e.g. an old srf could cause lots of problems with things like synchronisation which is why Siebel Anywhere makes the session read-only if parts of the configuration are out of date.

I would suggest you research the correct versions of you components and ensure you have them installed and also figure out why Siebel Anywhere sent you a set of version requirements but was not able to send you the right components to go with them..
0
All Courses

From novice to tech pro — start learning today.