Linux ftp server authentication error

Hi All,

We had an ftp server that...via a perl script, connected to another ftp server and copied files across.

All of a sudden the script stopped working.

We I do a normal ftp to the server...I get the following error

500 'AUTH GSSAPI': command not understood.
500 'AUTH KERBEROS_V4': command not understood.
KERBEROS_V4 rejected as an authentication type
Name ({ip address}:ipnd):

Ive restarted vsftpd daemon and looked at other things but I can not source what has changed.

Any ideas?
Network_PadawanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

savoneCommented:
First check for multiple servers running on the box your trying to connect to.

Can you the perl script, or at least the part that connects to the server?  (remove passwords and other sensitive info)
0
Network_PadawanAuthor Commented:
Hi,

Heres the code. As mentioned this code was working flawlessly until the server crashed. Rebooted and restart vsftp services and then thats when the script and ftp began producing errors.
#!/usr/bin/perl

use Net::FTP;
my $hostname = "x.x.x.x";
my $destdir = "upload";
my $errdir = "download";
my $user =  "username";
my $password = "password";

chdir($destdir);

my @files=<IPNDUPGLOGO.*>;
my $ftp = Net::FTP->new($hostname, Debug => 0) or die "Cannot connect to $hostname: $@";
$ftp->login($user,$pass) or die "Cannot login", $ftp->message;
#   chdir($destdir) or die "Can't chdir to $destdir $!";
    $ftp->cwd("upload") or die "Can't chdir to $destdir $!";
    foreach (@files) {
     $ftp->put($_) or warn "put failed ",$ftp->message;
  }

$ftp->quit;


system("mv * /home/ipnd/processed");

Open in new window

0
giltjrCommented:
Do you know if the vsftp server had been setup to support Kerberos?

The messages are saying that the ftp client is attempting to use Kerberos as an authentication method and the ftp server is saying that it does not support it.

So either the ftp server had been configured to support this and nolonger does or the ftp client has had something change to where it is trying to use Kerberos and the server never support it.
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

Network_PadawanAuthor Commented:
hi giltjr,

yes it always used kerberos

what other authentication methods are there? Ill test them out.
0
giltjrCommented:
Then something changed on the server, that is why you are getting:

500 'AUTH GSSAPI': command not understood.
500 'AUTH KERBEROS_V4': command not understood.

This says that the ftp server does not understand the AUTH commands that the client sent to it.

There is also SSL/TSL, however you can't just try them.  Well I guess you could, but your best bet it to figure out why the server all of sudden does not accept GSSAPI and KERBEROS as AUTH methods.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Network_PadawanAuthor Commented:
Ok, so how do i reinstall kerberos or fix it?
0
giltjrCommented:
First I would double check the configuration file on the server and make sure it still has the parameters needed, then make sure all of the packages needed are installed.
0
Network_PadawanAuthor Commented:
ok it works when I type ftp -u server

How do I script this "-u" in the perl script I had posted above?
0
Network_PadawanAuthor Commented:
I guess I just need to disable auto-authentication in the configuration. Do you know how to do this?
0
Network_PadawanAuthor Commented:
Hi, solved it.

Its got nothing to do with kerberos. It has to do with the script itself. Since its my failure Ill assign you points regardess.
0
giltjrCommented:
What OS are you running the script from?

What ftp client are you using?
0
giltjrCommented:
I made my last post before I realized that you had updated and closed it.

Thanks for the points, however I am a bit confused.  If the only thing that occurred was the server was re-booted, then I'm not sure how the issue was on the client.

Unless the server had been updated but never restarted and the update changed something that require a change on the client.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Server Software

From novice to tech pro — start learning today.