500 internal server error with phpMyAdmin

I have installed Apache 2.2.15 with MySQL 5.1.45 and PHP 5.3.2 on a Toshiba Qosmio X505-865 laptop (I need a mobile server) running Windows 7 (6.1, Build 7600). The directory structure for my server looks like this:
I have apache installed in c:\wamp\apache and phpMyAdmin is located in c:\wamp\apache\htdocs\phpmyadmin
So, my problem is this: when I try to log in to phpMyAdmin, the browser will appear to be waiting for the server to respond, but after about 10 seconds it will give up and return an HTTP 500 error. I have tried this with IE8 (8.0.7600.16385), Firefox 3.6.2 and Chrome 4.1.249.1042 (I realize all the version info is excessive, but I don't like to leave room for ambiguity). When I tried logging in through IE8, upon navigating to http://localhost/phpMyAdmin/index.php, a message popped up towards the top of the browser telling me that IE8's intranet settings have been turned off by default. I was unaware that IE8 has a different set of options for intranet sites vs. internet sites. So I went to tools->Internet options->Security and then clicked on "Local intranet" and then moved the slider all the way down to low. I tried once more on IE and it still exhibits the exact same behavior. Another thing I should mention is that the login page for phpMyAdmin was initially giving me a warning message saying something to the effect of "Cookies must be enabled beyond this point." I am 100% certain that I have cookies enabled on all three browsers, so that can't be the issue. I read on another forum that this particular issue could have to do with the windows firewall, so I completely disabled the windows firewall and the cookie message does indeed disappear when I navigate to the login page, but the aforementioned behavior persists.

I am also certain that mysql is working correctly, because I am able to create databases and tables and insert and delete records, etc. from the command prompt using mysql.exe

So, anyone have any ideas? If you need more information about my configuration, please let me know.
Lazarus_LongAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Member_5340450Commented:
You will find the answer in c:/wamp/apache/logs/error.log
0
kumaranmcaCommented:
Hi Lazarus_Long,

Start your server manually then. Check your server like http://localhost its working or not...
0
Lazarus_LongAuthor Commented:
To joomla_php: I have attached my error.log file. Note that today is 3/29/10 and I have attempted at least two more times to log in today. It does not appear that this HTTP 500 error is being logged into this file.

To kumaranmca: When I navigate to http://localhost/ I get a page that says "It works!". My installation of Apache came with a .html file in the htdocs directory containing this text in order to test to see if it works, and it does appear to be working fine. I am fairly confident that Apache, PHP, and MySQL are all configured correctly and working properly. I think the problem may either lie with my phpMyAdmin configuration, with my browsers, or even with Windows 7.
error.log
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

Member_5340450Commented:
hi - try attaching the other logs in that directory
THere is a message here about not being able to figure out the fully qualified domain name. Perhaps attach the conf directory httpd.conf file too
0
Lazarus_LongAuthor Commented:
Ok, here are the other logs. httpd.conf has been changed to httpd.conf.php so it would let me upload it here and httpd.pid has been changed to httpd.pid.log for the same purpose (I changed the names back after uploading).
access.log
httpd.conf.php
httpd.pid.log
install.log
0
Member_5340450Commented:
Does the site have an .htaccess?
If so could you remove/rename and go to phpmyadmin again to check if .htaccess is the issue?
Same for any files named php.ini. Remove/rename, re-start and re-check phpmyadmin.

0
Lazarus_LongAuthor Commented:
There are two files named .htaccess. One of them is in c:\wamp\apache\htdocs\phpmyadmin\setup\lib
and the other one is in c:\wamp\apache\phpmyadmin\libaries
I renamed both of them to old.htaccess and then restarted the Apache server. When I navigate to http://localhost/phpmyadmin/index.php the message "
Cookies must be enabled past this point." returns even though I continue to have my firewall off :(

As for the php.ini file, I do have one located in c:\wamp\php\ so I renamed it to oldphp.ini and then restarted the Apache server. When I navigate to http://localhost/phpmyadmin/index.php it gives me the following error "Cannot load mysql  extension. Please check your PHP configuration. - Documentation"
0
Member_5340450Commented:
Right the php.ini referred to here is "the" php.ini so you need that one. Sometimes there are override php.ini's that get in the way.
If it's not .htaccess then it's probably httpd.conf. Since I'm out of my league now, if it were me, I'd delete everything and re-install.
0
Lazarus_LongAuthor Commented:
I thank you for the effort. However, I really wish someone could help me with this since resolving this issue was my sole purpose for purchasing membership with this site.
0
Member_5340450Commented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Lazarus_LongAuthor Commented:
This suggestion may have lead to a solution.
0
ICTHelpdeskCommented:
I had a similar problem with PHPMyAdmin and WordPress on a 64-bit Windows 2008 (R2) Server.
To fix it, I had to uncomment the 'Localhost' reference in the Hosts file.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
PHP

From novice to tech pro — start learning today.