Filemaker Server Advanced 11 odbc driver & .asp problem with sql query - not showing results

Hi All,
I updated a server to FMSA11 today from FMSA10 and my website (ASP) queries (SQL queries via ODBC) no longer work. I have upgraded to the latest version of ODBC drivers from the FMSA11 install files and the ODBC connection tests are successful. Also, I found a post somewhere on the web that mentioned that the connection string format has changed, so I modified the connection string and I can see that my queries now connect and perform the queries (I have tested the INSERT and SELECT queries) - HOWEVER when running a SELECT query the results do not seem to write to the page.  It worked correctly as shown below for years before upgrading to FMSA11 - but now no longer works. Any ideas?

Here's what my query looks like:
set oConn = server.createobject ("ADODB.Connection")
oConn.Open Application("strConnect")
	strSQL = "SELECT box1_color, box2_color, box1_text, box2_text, box3_color, box3_text, box3_bgcolor, box3_fontcolor, box3_showhide FROM Graphix WHERE recid = 1"
		
	Set rsInfo = oConn.execute(strSQL) 
	If NOT rsInfo.EOF Then 
			box1_color = rsInfo("box1_color")
			box2_color = rsInfo("box2_color")
			box1_text = rsInfo("box1_text")
			box2_text = rsInfo("box2_text")
			box3_showhide = rsInfo("box3_showhide")
			box3_color = rsInfo("box3_color")
			box3_text = rsInfo("box3_text")
			box3_bgcolor = rsInfo("box3_bgcolor")
			box3_fontcolor = rsInfo("box3_fontcolor")
		rsInfo.MoveNext
	End If
rsInfo.Close
oConn.Close

Open in new window

LVL 1
BearRiverAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

BearRiverAuthor Commented:
Update: I ran some more tests and found that the results are writing number and date fields to the results, it's just the text field values that are not getting written
0
BearRiverAuthor Commented:
Any ideas why just the text field values would not be written to the screen?
0
BearRiverAuthor Commented:
In case anyone else comes up with this issue, I here is the answer:

"This problem appears to be related to previous issue when using FileMaker Pro 11 as a data source with Microsoft Word, where number and date fields are imported but not text fields.  The workaround is to specify the FileMaker validation option for maximum number of characters before you merge data.

TSGal

FileMaker, Inc."

So what you need to do for any text fields you are querying via .asp with ODBC is to set the field definition to validate for a max number of characters. I just gave it a test and it worked great.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
FileMaker Pro

From novice to tech pro — start learning today.