cisco phone

i contact to VOIP provider company to use VOIP Technology ,and we bought 24 cisco phone SPA 504g and cisco switch ESW500 supported VOIP and POE ,all these conected to LAN with server win2003 .But  when i conected the phones to our network and VOIP technician configured the phone as basic setting we didn't got the tone just i got four orrange lights ,VOIP technician told me the phone can't connect to the internet because there is some thing wrong in the DHCP , but the DHCP gives the ips to the phone and computers???
please advise me .  
wmoamerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

akahanCommented:
Can you ping the phones from other PC's on your LAN?
0
wmoamerAuthor Commented:
yes ,i can
0
akahanCommented:
OK, so we know the phones have received IP addresses, and DHCP therefore is NOT the problem.

Do the phones list the correct gateway address (generally, the LAN address of your router?)   (That is, if you press the menu button on the phone, just below the email button, and scroll down to "Network" in the display, and then to "Current gateway," do you see the IP address of your router?

If so, then at least the phones are configured correctly, and the problem is most likely either that your router is blocking something, or your phones haven't been provisioned by your VOIP provider.


0
ON-DEMAND: 10 Easy Ways to Lose a Password

Learn about the methods that hackers use to lift real, working credentials from even the most security-savvy employees in this on-demand webinar. We cover the importance of multi-factor authentication and how these solutions can better protect your business!

wmoamerAuthor Commented:
all the phone can get the gateway address ,DNS server address , i tried to add option 150 on the DHCP
as cisco web recomanded,but the same problem still? also i think there is port blocked on the router
0
akahanCommented:
Sorry, I do not understand your post....  What do you mean by "I tried to add option 150 on the DHCP"?
0
wmoamerAuthor Commented:
that is what i did :

issue:
Contact Failure Between the Cisco IP Phone and DHCP Server
Problem
The Cisco IP Phone fails to contact the DHCP server.

Solution
This issue can be addressed with this procedure.

Make sure these options are on the DHCP server:

Option 003: Default Gateway

Option 006: Domain Name System. (DNS) Servers

Option 015: Domain Name

Option 066: Boot Server Hostname (TFTP server) (Not Mandatory)

Define option 150 if the TFTP server does not have an entry in the DNS server.

Add a custom TFTP server. In order to do this, complete these steps:

Right-click the DHCP server and select Set Predefined Options.

Click Add.

Type TFTP Server IP address in the Name field.

Choose IP address in the data type list.

Type 150 in the Identifier box and click OK.

Select Option 150 from the Option Name under the Value section, type the IP address of the TFTP Server in the DHCP Options Default Values window, and click OK.

Add Option 150 in Cisco Network Registrar.

Select the DHCP cluster.

Go to the Advanced tab and click on Custom Options.

Click Add.

Enter Option number 150 and the Option Data Type of IP address. Click OK.

Go to the Policies tab and select your policy.

Add the custom Option 150.

Enter the TFTP IP address under IP address array.

Click on Always send to DHCP clients.

Enter Yes to commit the changes to the database.

but still the same issue ?


0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
wmoamerAuthor Commented:
i didn't add option 150 to cisco network register because voip hosted at voip provider.
0
akahanCommented:
What make/model router are you using?  The 150 idea does not apply/is not needed because DHCP seems to be working fine.
0
wmoamerAuthor Commented:
linksys  router rv042
0
akahanCommented:
OK.  To see whether you have a router issue (firewall, port forwarding, etc.), put one of the phones in the DMZ in the router.  That way, the router won't block ANYTHING going to that phone.  If the phone still doesn't work, I think the problem is almost certainly at your VOIP provider's end, not yours, and you should discuss / troubleshoot with them.
0
luc_roySystem AdminCommented:
OK I have used that same router to do this.

First test Does it work with the firewall off? yes or no?
0
wmoamerAuthor Commented:
thank you guys i found the problem , Our newer ESW switch, for example, implements a security smart ports policy that limits the number of MAC addresses that can be learned by a particular switch port when the IP+Desktop profile is used. and now the phones got the tone


0
akahanCommented:
D'oh!

0
wmoamerAuthor Commented:
i got the solution
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
iPhone

From novice to tech pro — start learning today.