• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1292
  • Last Modified:

How can i shrink the Exchange 2003 Mailbox store database?

we have an exchange exchange 2003 ent server.
I set a default mailbox limit on.
One of our user is getting a message that his mailbox is reaching the limit.
"Your mailbox has exceeded one or more size limits set by your administrator"
So even after archiving the mail to an pst file and removing the deleted mail, he still getting the warning message that he reach his limit.
After making a full backup, After running  the ESEUTIL /D, no errors but the database size stay the same.
And also the user keep getting the same limit message.
Also try restarting de Microsoft Exchange Information Store services and set the "Keep deletd items for (days) to 0".
In the AD the users setting in the Exchange General is set to default.
For some reason i can't shrink the database.

1 Solution
Glen KnightCommented:
Firstly the Exchange Database size has nothing to do with the users mailbox limit.  The reason you are probably unable to reduce the size of the database is because there is no whitespace.  Have a look at my article here that explains the process: http://www.experts-exchange.com/articles/Software/Server_Software/Email_Servers/Exchange/Exchange-Offline-Defrag.html

if you find the article useful please vote for it :)

as for the mailbox size limit.  This includes anything in deleted items and sent items.  In outlook right click where it says Mailbox - Persoms Name and select properties then click advanced.  Under here you should be able to view the size of all the mailbox.
The size of the database bears no relation to the mailbox limit. You shrink the store to free up disk space on the server if needed.
Check the properties of the mailbox, check the default limit for the store, and check the limit on the particular mailbox.
If the mailbox is still oversize, then it needs to be emptied more. I usually sort the display by the size column (add it by right clicking on the grey bar and go into 'field chooser') and it quickly shows large emails to clean out.
The server may also need to go through a maintenance process before it clears the mailbox. There may be an option to keep deleted items until a full backup has completed (have to research that one).

Sorry this is a bit vague, been a while since 2003.
is user using MS Outlook?
what email account type being used? POP3 or Exchange
exchange database size is not causing this error. this is because of user mailbox limitation you set.
(if you really want to decrease your database size, use offline defrag http://support.microsoft.com/kb/328804 )
what is your default mailbox size value? and what is the mailbox size of user ( open System Manager - server - first storage group - mailbox store - mailboxes - user size
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

SteveIT ManagerCommented:
Have you considered allocating more space to individual users or perhaps enabling auto-archive to a networked location (so its still backed up) which would reduce the user's mailbox size..........
xof64Author Commented:
Glen KnightCommented:
Would you mind explaining how the answer you have accepted resolves your problem?

PST files for a start are not supported on a network share.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Tackle projects and never again get stuck behind a technical roadblock.
Join Now