• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 761
  • Last Modified:

Exchange 2007 ActiveSync doesn't allow me to synchronize all of my e-mnails

I just bought an HTC HD2 (WM 6.5) and set it up to synchronize with our corporate Exchange 2007 server. However, I can synchronize maximum 3 days of e-mail and 1 month of past appointments, although I have other options on my Windows Mobile Device Center (Vista). I though that was a WMDC bug, so I hard-reset the phone and did a wireless synchronization, but the result was the same. So I figured out that this is a setting on Exchange 2007, and asked our admins to change it. However, they insist that there is no such setting on Exchange 2007, because WM is not our corporate smart phone OS standard, so they don't know much about ActiveSync settings. And of course, they are lazy!!! So could any of you Exchange 2007 gurus out there point me in the right direction so that I can synchronize all of my e-mails to my HD2?
0
egokcen
Asked:
egokcen
  • 6
  • 3
  • 3
1 Solution
 
MegaNuk3Commented:
You'll probably find that it is a phone setting.

I don't know about HTC's, but on my iPhone once you ave created the ActiveSync connection with Exchange you can change iPhone Exchange Account sync settings on the phone. The setting is called "Mail Days to Sync" and you can set it from "1 Day" all the way up to "No Limit".
0
 
Alan HardistyCo-OwnerCommented:
MegaNuke3 is correct.

Click on Start, Programs, Activesync (no idea where this might be if you are using TouchFlo as that's the first thing I turn off!), then in Activesync, click on Menu, Options (can't remember if this is the exact place - using an iPhone now), then you should be able to change the Calendar and Email options to choose a period other than default to sync.
0
 
MegaNuk3Commented:
After digging out my old windows mobile6.0 device...
Start-->ActiveSync-->Menu-->Options-->E-mail-->Settings

then I have the option called "download the past:" which goes from "1 Day" to "All"
0
Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

 
MegaNuk3Commented:
so alanhardisty has quite a good memory with regards to where to change it if you compare my post with his  ;-)
0
 
egokcenAuthor Commented:
Thanks for all of the replies. I  know how to change synchronization settings on the phone itself. But the only options I have for e-mail are 1 day and 3 days, and 2 weeks and 1 month for the calender ON THE PHONE itself. I have the full set (1 day - - All) BEFORE the first sync ON THE PHONE; all the rest disappear AFTER the first sync. That's what leads me to think that there is a specific setting on the Exchange server. Besides, I'm forced to enter a password for the device after the first sync, so there must be a specific setting on the server for this, too.

Here is what I'm doing in order:

- Hard-reset the phone.
- Setup the Outlook account MANUALLY ON THE PHONE without connecting the phone to the PC via USB cable.
- I see all the options for e-mail and calendar synchronization (1 day -- All and Past 2 Weeks -- Past 6 Months) ON THE PHONE before the first sync.
- I sync over the 3G network without connecting the phone to the PC via USB cable, and only 3 days of e-mail and 1 month of appointments are synced.
- I check the e-mail and calender settings ON THE PHONE; all the other options are gone!
- I connect the phone to the PC via the USB cable, and I see the full set ofoptions for e-mail and calender on Windows Mobile Device Center (WMDC).
- I set e-mail to All and Calender to past 3 months oON WMDC, and nothing changes on the mobile phone; the settings ON WMDC are totally ignored.

So, don't you think something is happening during the first sync which deletes the other options, and which causes the settings on WMDC to be ignored during the subsequent syncs? I strongly believe that it's all because of a setting on Exchange 2007.
0
 
MegaNuk3Commented:
Tell your Exchange admins to read these articles and then look on the server to see if there are policies in place:
http://msexchangeteam.com/archive/2007/05/23/439541.aspx

This one talks about a "maximum e-mail age filter": http://technet.microsoft.com/en-us/library/bb123484(EXCHG.80).aspx 
0
 
Alan HardistyCo-OwnerCommented:
Thanks MegaNuk3 - sitting in a hospital answering that one : )
0
 
egokcenAuthor Commented:
That should be it! I will let you know the outcome...
0
 
MegaNuk3Commented:
@alanhardisty - you must have good internet access because you are not posting via EE Mobile...
hope you are well. If you are on EE while you are visiting someone unwell then shame on you! ;-)
0
 
Alan HardistyCo-OwnerCommented:
@MegaNuke3 - Drop me an email via my profile - I'll fill you in, but posting on my iPhone - like a bad boy : (
0
 
egokcenAuthor Commented:
It worked. Thanks...
0
 
MegaNuk3Commented:
Thanks for the update and the points
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 6
  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now