[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 790
  • Last Modified:

Get Mailman to work with Qmail

I have QmAil installed on a CentOS5 machine and have been successfully using mailman for some time.

I upgraded my installation of PLESK to 9.0.1 which has stopped mailman from working as described elsewhere on the web.

The recommended fix is to insert a sym link to the mm_wrapper file which I have done using the commands:

cd /var/qmail/bin
ln -s /usr/lib64/plesk-9.0/mm_wrapper mm_wrapper

this link is created as expected.

Emails to mailing lists are still bounced with the message:

preline: fatal: unable to run /var/qmail/bin/mm_wrapper: file does not exist

I have tried restarting the service already.

Very keen to get this working!
   
0
markremms
Asked:
markremms
1 Solution
 
markremmsAuthor Commented:
:-)

The cause if the problem is some incorrectly updated packages caused by upgrading from the PLESK web interface.

Best to upgrade from ssh:
/usr/loca/psa/admin/sbin/autoinstaller

Running this fixed the problem.

0

Featured Post

The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now