disk quota in linux

Hi experts:

I have rhel5.4 working as a samba domain controller as /home with a separate partition, implemented the diskquota, i want to limit the disk space for the users in a group project1 to 250MB, hence any user in the group project1 can use maximum of 250mb.

# edquota -g project1
Disk quotas for group bttrans (gid 503):
  Filesystem                   blocks       soft       hard     inodes     soft     hard
  /dev/mapper/VolGroup00-LogVol02          0          0          0          0        0        0

-----------------------------------
please suggest me in which column i should set the 250MB. also will it accept the value 250MB if not then please give me the value of 250MB to be set.
Thanks in advance.

D_wathiAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Gregory_VCommented:
Take a look over:

http://www.redhat.com/docs/manuals/enterprise/RHEL-4-Manual/sysadmin-guide/ch-disk-quotas.html

 The first column is the name of the file system that has a quota enabled for it. The second column shows how many blocks the user is currently using. The next two columns are used to set soft and hard block limits for the user on the file system. The inodes column shows how many inodes the user is currently using. The last two columns are used to set the soft and hard inode limits for the user on the file system.

A hard limit is the absolute maximum amount of disk space that a user or group can use. Once this limit is reached, no further disk space can be used.

The soft limit defines the maximum amount of disk space that can be used. However, unlike the hard limit, the soft limit can be exceeded for a certain amount of time. That time is known as the grace period. The grace period can be expressed in seconds, minutes, hours, days, weeks, or months.

If any of the values are set to 0, that limit is not set.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Monis MontherSystem ArchitectCommented:
The blocks number depends on what your FileSystem block size is


Follow this tutorial to understand how to get it and set it

http://www.tcpdump.com/kb/os/linux/linux-quota-tutorial/intro.html

0
D_wathiAuthor Commented:
Thanks for the help, iam able configure the same also able to set the user wise quota  by executing the command
# edquota username
and by setting the values in 3rd and 4th cloumn
then when verify with
#quota username # this gives the value what ever value is set , hence this working fine

Problem is when try to set the group quota
#edquota -g bttrans
Disk quotas for group bttrans (gid 503):
  Filesystem                   blocks       soft       hard     inodes     soft     hard
  /dev/mapper/VolGroup00-LogVol02          0      92160     102400          0        0        0

after saving this file and execute the  command for testing
# quota -g bttrans
quota -g bttrans
Disk quotas for group bttrans (gid 503): none
please help me where iam going wrong in setting the group quota

for your reference
ls -al /home/aquota*
-rw------- 1 root root 16384 Mar 30 16:29 /home/aquota.group
-rw------- 1 root root 15360 Mar 30 16:22 /home/aquota.user

Please help me where iam i going wrong in setting the group quota.

Thanks in advance.










0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

Monis MontherSystem ArchitectCommented:
Did you add the grpquota mount option in /etc/fstab
0
D_wathiAuthor Commented:
Thanks for the reply.
 cat /etc/fstab
LABEL=/                 /                       ext3    defaults        1 1
LABEL=/boot1            /boot                   ext3    defaults        1 2
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
LABEL=/tmp              /tmp                    ext3    defaults        1 2

/dev/VolGroup00/LogVol00 /usr                    ext3    defaults        1 2
LABEL=SW-cciss/c0d0p6   swap                    swap    defaults        0 0
LABEL=SW-cciss/c0d0p7   swap                    swap    defaults        0 0
LABEL=/externaldrive    /external               ext3    rw,acl          1 2
LABEL=/extendedlogical  /extendedlogical        ext3    rw,acl          1 2

/dev/VolGroup00/LogVol03                /var            ext3    defaults       1 2
/dev/VolGroup00/LogVol02                /home           ext3    defaults,usrquota,grpquota      1 2
------------------------------------------------------
please help
0
Monis MontherSystem ArchitectCommented:
Ok now run

mount -o remount /home

Then

quotacheck -cug /home

Then

quota on /home

Then edquota and put your settings

To make sure its working fine

repquota

0
D_wathiAuthor Commented:
SIr , thanks for the reply

I tried as per your instructions still the group quota is not working , also trunned off the quota deleted aquota group and user files , restarrted the system again executed the
#quotacheck -cug /home
#quotacheck -avug

even now the user quota is working but the group quota shows none when verified even after setting the value

please help
0
D_wathiAuthor Commented:
for your information:
# edquota -g mttrans

Disk quotas for group mttrans (gid 504):
  Filesystem                   blocks       soft       hard     inodes     soft     hard
  /dev/mapper/VolGroup00-LogVol02          0      92160     102400          0        0        0
---------------------------------------------------------
#quota -g mttrans
quota -g mttrans
Disk quotas for group mttrans (gid 504): none

please help me to fix this.


0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.