Trouble with certificate when connecting to an RDP file

Hello Terminal Services Experts,

I’m trying to learn Terminal Services in Windows Server 2008.  I have read several articles and the Terminal Services chapters in various books, but I know there is no substitute for getting my hands dirty and playing with Terminal Services in a lab.  I have installed Terminal Server on a Windows Server 2008 system in a test lab.  I decided that a good place to start would be to try out the RemoteApp feature.  One of the articles I have read provided the steps to make the calculator on the server a remote app.  I followed the steps in the article and made a RDP file for the server’s calculator.  When I try to access this RDP file, I get the following message.

Your remote desktop connection failed because the remote computer cannot be authenticated.

The certificate is not from a trusted authority.

The client that I’m using is an XP Pro workstation with SP3 installed.  However, when I try to connect to the RDP file from the terminal services server, I get the same message.  I have verified that the NLA is not enabled on the terminal services server.  

Any help with this would be greatly appreciated.

Regards,
Nick
LVL 1
ndalmolin_13Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

linrafCommented:
On the RDP client on the xp machine.
Options
Advanced
If server authentication fails
If you set this to warn me, I believe it will give you a notice, but ask you if you want to connect.

You should also be able to install the certifacate in internet explorer to make it  a trusted cert.
0
Alex AppletonBusiness Technology AnalystCommented:
This is an expected outcome.  Sounds to me like you are using a self-signed certificate.

On the terminal server, open the terminal server configuration snap-in and check the properties of the rdp-tcp.  Under the general tab at the bottom is the listed certificate for the connection.  I think default is self-signed.  

For a lab, make another server a CA and generate a certificate request from your TS to sign the connection.  In a real world deployment you are going to want to use a 3rd party CA to accomplish this task.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ndalmolin_13Author Commented:
Is there a way to configure the terminal server to not use a certificate in the lab?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.