New SSP Administration link shows 404 error

I created a first SSP in a new MOSS 2007 installation, but the new Shared Services Administration link shows HTTP 404 error-Not found.

The creation of SSP was complete and it showed the services in the SSP.

I am using IIS7 on Windows 2008 Server.

What can be going wrong?
LVL 1
PaawanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ted BouskillSenior Software DeveloperCommented:
When you created the SSP did you create both the web application and the site collection for it?
0
PaawanAuthor Commented:
After I configured the search and query service in the farm I created SSP in the following order.

1. New SSP
2. In the New SSP page I used the links in there to create the two new application. (No site collection was created)
3. New SSP Created successful message got displayed with all those services running.
4. On the central admin site as I click the new SSP under "Shared Services Administration" on the left menu

It says "Server Error is Application : Default Web site" HTTP Error 404.0 - Not Found

I am using Windows Server 2008, IIS 7

Another issue is eventhough the Search Services displayed as started, the log issues with propogation, so I restarted again and now I ensured its working. But during the creation of SSP I doubt it was not working properly.
0
PaawanAuthor Commented:
Few more things to add on to the discussion...

I have three servers with complete installation of MOSS
Server A - With Search Service + Central Admin
Server B - Query Service and Excel
Server C - Query Service and Excel

From the Central Admin as I create SSP and Applications, I can see the applications are created in Server B and Server C.

My requirement is to Create an SSP in this farm with host header http://intranet.cbs.in

Thanks

0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

irinucCommented:
If your firewall is on, you need to add inbound/outbound rules for the port where SSP is running. (at least this is what I missed and got a similar error).
Hope this helps.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
PaawanAuthor Commented:
I already enabled the ports and it worked out well for a new SSP.

But the old SSP whose sites are on Port 80 still didnt work, I guess even though the ssp creation displayed successful due to the firewall I suspect it didnt create the web applications.

Also let me know how the host header works? Do we need to configure the DNS server as well or just by providing the intranet.cbs.in in the host header field while creating the application will work?
0
irinucCommented:
I don't think the firewall might have interfere with the creation of the web application. Rather, the fact that the SSP is on port 80 might have something to do with this.

Anyway, here is a post for an user having a somehow similar issue
http://social.technet.microsoft.com/Forums/en-US/sharepointadmin/thread/4ac4343f-02e6-468d-813e-03f3d1b445a0
And here is another user's experience on host headers in SSP - this may provide some info on how to setup
http://www.infopathdev.com/blogs/janice/archive/2009/02/16/sharepoint-host-headers.aspx

That's all i know on host headers :-)
Hope this helps at least with some ideas on where to look.
Cya.
0
Ted BouskillSenior Software DeveloperCommented:
You MUST create a site collection for the SSP web application.  Without it there are no pages to display.

Plus you cannot create an SSP central administration site at the root.  It will always be http://<host header>/SSP/Admin/...

Yes it sucks but that is the way Microsoft did it.
0
PaawanAuthor Commented:
from what irinuc: comment, i really dont know why Port 80 cannot be used.
But I succeeded in using a different port and its now working fine.

Thanks for the suggestions.
0
PaawanAuthor Commented:
Eventhough I was not clear about the reasons of why not? I created the applicaions on different port other than Port 80.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.