module not autoloading in asterisk 1.4

We are using asterisk 1.4.22

I've compiled speex for asterisk and codec_speex.so is in /usr/lib/asterisk/modules

In modules.conf I have it set to autoload=yes (I've even tried explicitly loading speex, no go)

The module is not loading and when I do a module show list or module load ? at the CLI codec_speex.so is not shown.

Any ideas?

Thanks
pazzaTimAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

nasirbestCommented:
if speex is compiled and installed properly then you have to check that asterisk has proper access on it
0
pazzaTimAuthor Commented:
when I did the make menuselect it showed up as selected not XXX as before.   The make for asterisk created and then moved the code_speex.so file to /usr/asterisk/modules.

It SHOULD load.  Just does not, nor show up in the list of modules from within the CLI
0
nasirbestCommented:
1. stop the asterisk
2. start it again with    asterisk -cvvvvvvvvvvvvvvvvvvvvvv
3. search for speex in log, if you found any error regarding speex let us know
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

pazzaTimAuthor Commented:
Ahhhh..  Progress

[Mar 29 14:23:46] WARNING[5441]: loader.c:359 load_dynamic_module: Error loading module 'codec_speex.so': libspeexdsp.so.1: cannot open shared object file: No such file or directory
[Mar 29 14:23:46] WARNING[5441]: loader.c:653 load_resource: Module 'codec_speex.so' could not be loaded.
0
nasirbestCommented:
OK, you got the problem now we try to fix it.

you must have libspeexdsp.so.1 in library include paths like /usr/lib and /lib

but if you have compiled libspeex by yourself then it may be in /usr/local/lib/ which I think wrong. in this scenario recompile your libspeex with following options.

make clean
./configure --prefix=/usr
make
make install

then for asterisk
make clean
./configure
make menuselect         and confirm for speex
make
make install
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pazzaTimAuthor Commented:
Exactly right to a 'T'.

The lib was in /usr/local/lib.  Your instructions worked perfectly.  

Much thanks.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
IP Telephony

From novice to tech pro — start learning today.