PHP and windows7

I have windows 7 and am trying to get PHP to work. I have installed PHP and mysql. Mysql administrator works fine but when I try http://localhost/test/index.php I get this error:

HTTP Error 404.3 - Not Found
The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.

Any ideas? I am using IIS 7.I got it working perfectly on my XP machine.
jonofatAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kumaranmcaCommented:
Hi Jonofat,

First you test your server...like

http://localhost -- its working or not. Then

404 found error means. Its not in your folder path "test". Kindly check your folder path.. Then test it...
0
kumaranmcaCommented:
sorry,

index.php file not in test folder. check your file path...
0
jonofatAuthor Commented:
HI, yes, http://localhost works. I fiddled around a bit and now get this error:

HTTP Error 500.0 - Internal Server Error
C:\PHP\php-cgi.exe - The FastCGI process exited unexpectedly
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

jonofatAuthor Commented:
I have added *.php in IIS and I now get the following:

HTTP Error 500.19 - Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid.

 4:         <handlers accessPolicy="Read, Execute, Script">
    5:             <add name="PHP" path="*.php" verb="*" modules="FastCgiModule" scriptProcessor="C:\PHP\php-cgi.exe" resourceType="Unspecified" />
    6:         </handlers>

Any ideas anyone?
0
kumaranmcaCommented:
I think check your file permission of index.php if you have 777 permission. To get 500 Internal server error is possible change the permission 664. and test it
0
jonofatAuthor Commented:
It seems all my permissions are correct. Just don't know what this means though

C:\PHP\php-cgi.exe - The FastCGI process exited unexpectedly
0
jonofatAuthor Commented:
Never mind. I figured it out. I tried running php --info from the dos promt and it told me I was missing Libmysql.dll so I downloaded it and pasted it into my PHP directory and it works! :)
0
ee_autoCommented:
Question PAQ'd, 500 points refunded, and stored in the solution database.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.