Trouble with Netgear router working with DSL modem/router

I've been working on getting a wireless router to work with a DSL modem from AT&T.  

They are using a Motorola MSTATEA modem (with built in DHCP) from AT&T
The router is a Netgear WGB511 Wireless Router.

With only the laptop connected directly to the modem, the internet connection works.  The modem normally has an internal DHCP server and automatically connects with the DSL login/password.  It also has an internal webpage management to configure the modem and turn these features on and off.

When the Netgear router is connected into it, it will not get a DSL based connection.  I've otherwise tested the username/password and confirmed we were using the correct ones.  I can login to the router's configuration webpages.

If anybody has worked with this combination of router/modem before, I'd appreciate the help!
JohnCramer_6SCITSAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ElrondCTCommented:
I think the easiest way to do this, assuming you won't have any need for external users to connect in to your router or computer (you're not running a web server or anything like that), is going to be to not try to make your router log in. Instead, let the modem handle the login, and treat the router as a second-level network; give it a static or dynamic IP on the WAN side, rather than using PPPoE. It'll be less confusing and prone to problems if you have a different subnet for it; so, for instance, if the modem's default gateway (when you plug the laptop directly into it) is 192.168.0.1 (or any other last number after the dot), your router should be 192.168.xx.yy, where xx is anything other than 0, and yy can be whatever you like that won't confuse your DHCP scheme.
0
JohnCramer_6SCITSAuthor Commented:
Thanks, I'll try this tomorrow morning when I go to work on the system.  It's a household network, so no big fancy servers or anything.  I had tried turning off the routing on one or the other and it didn't work, but I haven't tried a different subnet yet.
0
inbox788Commented:
I've used PPPoE on the modem as well as the router, and it doesn't generally make a difference either way as far as function. Setting up the modem to do PPPoE would very likely work just fine. However, I've found setting up routers is simpler than modems, and centralizes configuration to one device. That said, here are a couple of things to check.

First off, make sure there is no subnet conflict by checking that the IP on the WAN side isn't the same range as the LAN (i.e. both 192.168.1.xxx).  Second, check that you're using a full login name (i.e. user@domain.com and correct password) and that you're getting the IP and DNS from your provider. It should work, and it's simpler to setup IMHO.

BTW, just to be clear, what exactly do you mean by "it will not get a DSL based connection". Does the router attempt to login to the PPPoE account and fail? What error is given and what lights if any aren't coming on?


0
Redefining Cyber Security w/ AI & Machine Learning

The implications of AI and machine learning in cyber security are massive and constantly growing, creating both efficiencies and new challenges across the board. Join our webinar on Sept. 21st to learn more about leveraging AI and machine learning to protect your business.

JohnCramer_6SCITSAuthor Commented:
Sorry, but this will be a slow response as I get this problem worked out, I hope you all will bear with me as I try the different solutions.  I'll be fixing this remotely as I've actually moved this week overseas, but we haven't had a chance to try anything new since the 28th.  

Here are some more details and answers to some of the questions.
The network is a residential DSL, at the home of friends of my parents.  I will be telling my dad what he should do and try (he's also a computer guy and is the one who originally configured the internet at the house).  

We were able to test the login name and password we're using and it is correct.  The router is not responding with an error of any kind.  It just continues to report the status as 0.0.0.0 for all of the IPs assigned after you tell the router to connect.

The first thing is going to try is to use a different router - a Linksys Linux based router with Tomato firmware.  The current configuration of this other router already has DHCP and is basically configured as a Wireless access point.  

IF that doesn't work he will try adjusting the subnet.

I'll keep new progress posted, but the work might be spread out over the next week or two.
Again thanks for the answers so far.
0
inbox788Commented:
When you get a chance, get the router status results and paste them here. This is a result from another Netgear router, but the fields should be pretty much the same. Are you saying the Internet Port IP address is 0.0.0.0? That's very strange.

Router Status
 
Account Name
Hardware Version
Firmware Version  
 
Internet Port  
MAC Address  
IP Address  192.168.x.x
DHCP  DHCPClient
IP Subnet Mask  255.255.255.0
Domain Name Server
 192.168.x.x

 
LAN Port
MAC Address  
IP Address  192.168.x.x
DHCP  ON
IP Subnet Mask  255.255.255.0
 
Wireless Port  
Name (SSID)
Region United States
Channel 1
Mode Up to 130Mbps
Wireless AP ON
Broadcast Name ON
 
0
chillguyCommented:
Go into the Router's main page --> Turn off NAT
                  Access Modem's page --> Input your connection details into the page and save.

The above should now make your router into an access point and your modem into a router. This is exactly what I did with AT & T.

Goodluck!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JohnCramer_6SCITSAuthor Commented:
We haven't solved this problem using the netgear router, but we did bring in the Linksys router (with Tomato firmware) which had already been configured as an access point instead of a router.  It worked when first connected.  I've attached a screenshot of the initial page from the router.
linksys.jpg
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Hardware-Other

From novice to tech pro — start learning today.