my usb ports stop working after resumeing from hibernate or sleep

i upgraded my OS from windows vista business to windows 7 ultimate ,and after the upgrade every thing was working fine

after a while when my computer resumes from sleep or hibernate all of my USB ports stops working!!!

and also when this happens I try to restart or shutdown my computer it just goes for ever and i am forced to a manual shutdown with the power button

i am using a lenovo T61 Laptop ,and my OS is fully updated

so i guess that i need some help here ... please.
LVL 1
ConnecterAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

LazloHCommented:
there is a feature in the power management portion of the control panel that will actually put USB ports to sleep on hibernation.  It sounds like yours just are not recovering from it.  I am not on windows 7 at the moment to walk you through it though.  Check there first.  I also found this

http://www.pcauthorities.com/drivers/how-to-disable-power-management-on-usb-root-hub

Might help you out as well.  Let us know if it works for you.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
centervCommented:
Upgrading these days seems to be always problematic.
Wonder if you had these updates in Vista prior to upgrading
http://support.microsoft.com/kb/941600 

You can also go to device manager usb root hub/properties/power management and uncheck
to allow computer to disable to save power.

All else failing, I would use a repair install of win7.
0
robgolden82Commented:
I have experienced this issue with a wireless USB NIC not working after hibernate/sleep.  In device manager, right click the USB hub and choose properties.  In the power management tab uncheck "Allow thie computer to turn off this device to save power."  This solved my problem.  However, I believe Microsoft release a patch for this issue, so you may want to also explore that possibility.
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

cantorisCommented:
As well as disabling power management on the USB Root Hubs, try upgrading the chipset driver - eg from Intel's site directly if it uses an Intel chipset.
0
BitsBytesandMoreCommented:
IBM/Lenovo has many issues with Windows 7. Mainly because of BIOS problems. Go to the Lenovo support site http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-67853 and download and install the latest BIOS. It corrects many issues related to problems with Windows 7.
This said, be careful. Follow the instructions to the letter. Really!   A failed BIOS installation can ruin your computer.
Bits .....                        
0
BitsBytesandMoreCommented:
Forgot... make sure you download the correct BIOS for your system: Triple check!!
Bits ...
0
ConnecterAuthor Commented:
well i already tried this update
http://support.microsoft.com/kb/941600
it works only for vista.

but the solution (usb root hub/properties/power management and uncheck
to allow computer to disable to save power) works fine until the first restart of the computer.
and i can concider it as a temp solution if i decide to keep my computer in hibernation with out any shutdown or restarts.
because when you restart you have to go back and uncheck them all .... !!!!!

so i figured this solution:
because of the windows power plans ,USB ports are by default enabled for suspend .
so when you restart the (allow computer to disable to save power) check box is checked again

so this is what i have done:
1.control panel
2.power options
3.click on (change plan settings) of the active power plan
4.then click on (change advanced power settings)
5.for each power plan in the drop down list expand USB settings and then expand USB selective suspend settings and then chagne both modes (on battery ,pluged in) to disabled

every thing is now working great
thank you all for the help
0
centervCommented:
Cheers!
0
BitsBytesandMoreCommented:
Centerv.... how old are you? ...lol.
0
centervCommented:
Tons!  More than I care to remember and enough to get into plenty of troubles  LMAO

Peace! Bits
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.