sql error named pipes shared memory

A connection was successfully established with the server,  but then an error occurred during login process. Provider shared memory provider error: 0 – no process is on the other end of the pipe Error 233
this is the error when database was trying to be accessed using sa account.
named pipes is disabled. could that be the problem
LVL 1
sqlserverdbaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

garethh86Commented:
Is SQL authentication enabled on the server? Would also check that SQL Browser service is started.

http://support.microsoft.com/kb/914277
0
garethh86Commented:
How to enable SQL Authentication:

http://kbase.gfi.com/showarticle.asp?id=KBID002804

It's meant for enabling reporting for GFI but the process and images are the same.
0
sqlserverdbaAuthor Commented:
yes sql authentication is enabled
0
garethh86Commented:
Ok, that was the obvious one, here's a list of what could be wrong, trial and error and see where you get:

Enable 'Named pipes' in configuration manager

Too many connections open to the server (Increase maximum connections allowed, see below)

Disable Shared memory protocol

Make sure that the sql account has a default DB assigned

Delete any ailiases


==============
Make sure there are no open connections to server and run the following script, right click server and stop and start after runnning, will set maximum number of allowed connections to unlimited.


EXEC sys.sp_configure N'show advanced options', N'1' RECONFIGURE WITH OVERRIDE

GO

EXEC sys.sp_configure N'user connections', N'0'

GO

RECONFIGURE WITH OVERRIDE

GO

EXEC sys.sp_configure N'show advanced options', N'0' RECONFIGURE WITH OVERRIDE

GO




If none of this works then please look at the sql log for anything fishy:

(by default located in the C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\LOG directory).
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2005

From novice to tech pro — start learning today.