VMWare Guest Can't Access Shares on Host Server

Host Machine running Server 2003 sp 2 and VMWare Workstation 7.01.

Guest Machine is Server 2003 R2.

The Guest Machine can see (and be seen by) all computers on the network and it can ping (and be pinged by) the host, by name.  The Guest Machine can also access all other shares on the network.

However, opening windows explorer and trying to access \\host\share  (it's a good share that everyone else can see all over the network), times out.

Trying the NET USE command gets an error 67, network name cannot be found.

But pinging the host by name works.

Any ideas?

Thanks.
gateguardAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Paul SolovyovskySenior IT AdvisorCommented:
Try mapping via IP address.  Also make sure the VM is configured in bridge mode.  
0
coolsport00Commented:
Have you enabled sharing?
See pg. 190-191:
http://www.vmware.com/pdf/ws7_manual.pdf

Regards,
~coolsport00
0
gateguardAuthor Commented:
It is in bridged mode (could it see the rest of the network otherwise?) and net use \\ipaddress\share gets the same error 67.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

gateguardAuthor Commented:
Whoops.  I made a mistake.

I have  a server running VMWare Workstation 7.01 and another running VMWare Server 1.0.9.

This problem I'm having is on a Server 2003 sp2 Host running VMWare Server 1.0.9.

The guest is the way I said, though, Server 2003 R2.

Sorry about the confusion.  Should I ask to have this question deleted and start over?

Otherwise, the problem is the same, and there is no Sharing in Options on Server 1.0.9.

But anyway, the host can see the guest shares... it's the guest who can't see the host shares.

0
coolsport00Commented:
Nah...you should be ok, as long as it's now clarified. :)

I came across this MS KB...did you try it?
http://support.microsoft.com/kb/875441

~coolsport00
0
Paul SolovyovskySenior IT AdvisorCommented:
From the guest try to do a nslookup, make sure the ip matches hostname. Also check you arp tables on the guest to make sure it's picking up the correct mac for the host and not the mac for the nat mode virtual nic.
0
gateguardAuthor Commented:
I'm being warned that this is an abandoned question so I'm putting this note here to keep it active.

Nothing so far has worked... nothing.  Not the solutions offered in this thread or in any thread I've read on this subject on the internet, including threads regarding the EXACT SAME PROBLEM for LINUX users!

There is SOMETHING about guest-accessing-host-share that is problematic.

Today I think I stumbled on a solution.

But before I post that solution here I want to do some more testing to make SURE it works.

0
coolsport00Commented:
Ok...well, please keep us posted. :)

~coolsport00
0
gateguardAuthor Commented:
ok, it's fixed.

Here's what I had to do:

I added a second nic card to the vm and chose custom networking and then chose one of the 2 vm nic cards (VMNet1).

Then I manually gave it an ip address that was on the same network as the host machine's VMNet1 card.

On the host machine, VMNet1 has an address of 172.16.112.1 255.255.255.0, no gateway.  I have the vm's new nic card 172.16.112.2 255.255.255.0, no gateway.

Then, in the vm, I edited the hosts file with this line:
172.16.112.1 hostmachinename

It worked.  I did the same thing on all the other vm's on this host server, incrementing the ip address in each case, of course, and editing the hosts file on each machine (only with the hostmachinename, they can talk to each other over their 1st bridged nic card).

So now all the vm's running on the host server can see the share published on the host server and all are happy and I am happy and I am also very appreciative of the help given here (as always) and the only remaining task is to close this question in such a way that this note gets marked as the solution so that when others run into this problem they will be directed to the solution.

How do I go about doing that?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
coolsport00Commented:
Click on the link below your comment that says something like "accept as solution" and that should do it...

Glad it's resolved and thanks for posting the answer.

~coolsport00
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.