Remote Desktop Not Working, Even Locally

W2K3 R2 x64 with all updates applied.

Remote desktop stopped working on this system for seemingly no apparent reason (no updates or changes were applied).

Windows Firewall is off
Remote desktop is enabled
Terminal Services is running

When I try to a telnet 192.168.1.1 3389 it fails:

Connection To 127.0.0.1...Could not open connection to the host, on port 3389: connect failed

Even when I try to do a 'telnet 127.0.0.1 3389' it fails.

Any ideas?
jonisgoneAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

InderjeetjaggiCommented:
- Disable the antivirus and firewall associated with antivirus and check if it helps
- Try to reboot the server

Let me know if this works
inder
0
jonisgoneAuthor Commented:
Thanks Inder, but this has already been tried.  Also this server has no antivirus / firewall enabled.
0
kelvinightCommented:
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

jonisgoneAuthor Commented:
Thanks, installed the hotfix and still nada, although it didn't ask me reboot my system so I didn't.

Once we have a maintenance window to reboot this server I'll post back if this hotfix actually did work.
0
ChickensaurCommented:
Did someone change the default RDP port?  I would double check the port number by going into the registry and heading over to this key (just in case you didn't know where it is).

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber
0
jonisgoneAuthor Commented:
Doublechecked, still 3389.
0
ChickensaurCommented:
Ok...well then...this is an odd one but my own research has turned this up a few times.  Try updating your video card drivers.  I have no idea why this works but there are a number of people who said this worked for them.

Also a few that says it has to do with one of the updates for .NET3.0.  Maybe try uninstalling some of the .NET related updates.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jonisgoneAuthor Commented:
Thanks Chickensaur.  We did do some .NET updates on that box, I'll roll them back and post what I find.

0
sfossupportCommented:
Lets look at what ports are open and watch what happens when we try and connect. Download tcpview from sysinternals to watch ports in action

http://technet.microsoft.com/en-us/sysinternals/bb897437.aspx
0
jonisgoneAuthor Commented:
Removed the last few updates for .NET 3.5 and .NET 3.0 worked.  Thank you everyone!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.