?
Solved

NTP not giving the right time but date is good

Posted on 2010-03-29
6
Medium Priority
?
758 Views
Last Modified: 2012-05-09
Hello everyone
I just finished configuring my CME router and registered my first IP phone with success but i seem to have a problem with my NTP server configurations on the CME router.
If I type "show clock" the router gives me the right time and date exactly the way it should be but on the phone itself it gives me 4 hrs difference with the right date. If I look on my switches I also receive the right date and time the way it should be. The only problem is the time on the phone itself.
Here are the configurations of the router for NTP. By the way i'm in Toronto Ontario timezone


clock timezone TORONTO -5
clock summer-time TORONTO date Mar 14 2010 2:00 Nov 7 2010 2:00
ntp clock-period 17178019
ntp server 128.100.100.128
ntp server 128.100.102.201

CME_router#sh r
Mar 29 22:51:08.980: %SYS-5-CONFIG_I: Configured from console by marc on console
****Here it shows that I configured it 4hr difference then below.

CME_router#show clock
18:51:11.400 TORONTO Mon Mar 29 2010  ****notice the time and date are what it should be

Now if i look on the phone itself it says:
22:57p 03/29/10
Again here I have 4hr difference than the actual time.

I did some searching and it may be due to missing the configuration with recurring command but am not sure how to do this or if this is my problem or not.
clock summer-time zone recurring [week day month hh:mm week day month hh:mm [offset]]

Any help would be greatly appreciated.
Thanks very much

0
Comment
Question by:ibanez7
  • 5
6 Comments
 
LVL 25

Accepted Solution

by:
Ken Boone earned 2000 total points
ID: 29031672
There is another command needed in under the telephony-service component of the config with CME.  Here is a doc that shows what you need to do:

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/command/reference/cme_t1ht.html#wp1023398
0
 

Author Comment

by:ibanez7
ID: 29043154
Thanks very much for your help kenboonejr

Unfortunately it still hasn't changed anything. It's presently 9:44pm on my pc, 9:45pm on router, 9:46pm on switch B , and 9:47pm on switch A and my 2600 router also receiving NTP from the CME router which covers pretty much my network. Everything is getting the proper time from my router but the phone is still 4hrs ahead of the router. I configured it as so:
CME_router(config-telephony)#time-zone ?
  <1-53>  select timezone name used by IP phones (offset in minutes)

12 Eastern Standard/Daylight Time -300  ***this should be in Toronto Ontario Canada correct?
Therefore command:
CME_router(config-telephony)#time-zone 12
But still the same. Phone registers with Cisco CUCME date is still good but 4hrs ahead of time.
As you can see here all seems normal here.

switch_B#show cdp neigh
Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Switch_A         Fas 0/24           164          S I      WS-C2950-2Fas 0/24
SEP9CAFCA84375F  Fas 0/6            169          H P      IP Phone 7Port 1

switch_B#show ntp assoc
      address         ref clock     st  when  poll reach  delay  offset    disp
*~172.16.2.1       128.100.100.128   3    27    64  377     2.9    0.40     0.1
 * master (synced), # master (unsynced), + selected, - candidate, ~ configured

switch_B#show ntp status
Clock is synchronized, stratum 4, reference is 172.16.2.1
nominal freq is 250.0000 Hz, actual freq is 249.9966 Hz, precision is 2**18
reference time is CF5BDB7D.9B18BEA1 (22:07:57.605 TORONTO Mon Mar 29 2010)
clock offset is 0.3486 msec, root delay is 60.79 msec
root dispersion is 44.72 msec, peer dispersion is 0.11 msec

I rebooted the phone a couple of times and still the same.
Good idea though
0
 

Author Comment

by:ibanez7
ID: 29044152
I just read a little further and I do believe you were right and I didn't read far enough. I'll complete the configuration tomorrow morning and post back.

Usage Guidelines
For changes to the time-zone settings take effect, the Sep*.conf.xml file must be updated by using the create cnf-files and the Cisco IP phones must rebooted by using the reset command.
I rebooted the phone but didn't recreate the cnf-files.

Will try first thing tomorrow morning. Thanks again
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 

Author Comment

by:ibanez7
ID: 29087424
Ok I tried it and it still giving me the same time I had last night. The date is fine but the time is still out of whack , it doesn't even seem to change..
I configured the time-zone 12 and re-created the cnf-files then reset the phone and still the same.
It also shows that I configured it on the right date but it is showing March 30 12:31:33 p even though it's now 8:37am on March 30/2010
CME_router(config-telephony)#create cnf-files

Mar 30 12:31:33.097: %IPPHONE-6-REG_ALARM: 25: Name=SEP9CAFCA84375F Load= SCCP11
.8-3-3SR2S Last=Initialized
Mar 30 12:31:33.125: %IPPHONE-6-REGISTER_NEW: ephone-1:SEP9CAFCA84375F IP:172.16
.1.11 Socket:1 DeviceType:Phone has registered.

This is what i have for ntp now:
clock timezone TIMMINS -5
clock summer-time TIMMINS date Mar 14 2010 2:00 Nov 7 2010 2:00
 ip source-address 172.16.1.1 port 2000
 time-zone 12        *****TIME ZONE FOR TORONTO ONTARIO CANADA
 max-conferences 4 gain -6
 transfer-system full-consult
 create cnf-files version-stamp 7960 Mar 30 2010 08:23:18  ****SHOWING RIGHT TIME WHEN CREATING
 ntp clock-period 17178019                                                                                                CNF-FILES
ntp server 128.100.100.128
ntp server 128.100.102.201

I do however have ACL stopping all pings between the 172.16.2.0 and 172.16.1.0 and also all pings coming from outside. Would this make a diffrence?

Thanks for the any help with this issue.
0
 

Author Comment

by:ibanez7
ID: 29110480
OK....finally figured it out
There is no "its" file created. The phone is booting with the default file which has no time-zone specified in it. That's why the the rest is all good except for the time.
To fix this issue:
Create ephone, add the phone mac-address and type 7906 or whichever phone you are using, then go into telphony-service to configure the time-zone and the cnf-file. Reboot the phone
Then you'll see your new cnf-file with time-zone included.

Voila... the 7906 is now recieving the proper time.

Thanks very much for the help and link you gave me. This wasn't all that was required but it did give me a push in the right direction to get this going so i'll give you all the points anyway.
0
 

Author Closing Comment

by:ibanez7
ID: 31708672
Thanks very much for the push in the right direction.
0

Featured Post

[Webinar] Kill tickets & tabs using PowerShell

Are you tired of cycling through the same browser tabs everyday to close the same repetitive tickets? In this webinar JumpCloud will show how you can leverage RESTful APIs to build your own PowerShell modules to kill tickets & tabs using the PowerShell command Invoke-RestMethod.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There are no good configuration guides for HP-H3C router to LYNC on the web. :( Big statement, but we havent been able to find one yet. We did find the following document useful, but the information was not enough to use H3C router for use as a L…
Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

592 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question