• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 347
  • Last Modified:

Accessing Windows 7 Files

OK.. so my Win 7 notebook crashed, I have to transfer files from My Documents to an XP machine while it gets fixed... but I can't access the files on the notebook drive because Windows 7's new approach to file permissions won't let me just get in like XP would have.... even when the drive is mounted as an external on an XP system.

I like the new approach to security - it just seems like, as usual, the ones that are paying for it are .. well, us..

Thanks!  wj
0
Wes Jones
Asked:
Wes Jones
  • 3
  • 2
  • 2
  • +1
2 Solutions
 
centervCommented:
Be sure you look at the links and comments for further input.
Good luck

http://www.blogsdna.com/2159/how-to-take-ownership-grant-permissions-to-access-files-folder-in-windows-7.htm 
0
 
LeeTutorretiredCommented:
Have you tried taking ownership on the XP machine?  Go to the folder on the notebook drive
Right Click the user folder and select Properties
Go to the Security Tab
Select Advanced
Go to the Owner tab
Select "take ownership"
Once ownership is taken, you can give yourself permissions.

Note: this only works if you are an administrator on the machine.

More info: see these MSKB articles:

http://support.microsoft.com/default.aspx?scid=kb;en-us;308421
HOW TO: Take Ownership of a File or Folder in Windows XP

http://support.microsoft.com/default.aspx?scid=kb;en-us;308418
HOW TO: Set, View, Change, or Remove File and Folder Permissions in Windows XP

If you don't see the Security tab, you will have to first disable Simple File Sharing in Windows XP Pro by clicking the Tools menu in Windows Explorer, selecting Folder Options, then the View tab, and then removing the check mark next to Use Simple File Sharing.  If you are using XP Home, then you will need to boot into Safe mode and login as Administrator to access the Security tab.
0
 
centervCommented:
Here's another perhaps clearer link. Same applies if you're using xp to get the files

http://www.addictivetips.com/windows-tips/windows-7-access-denied-permission-ownership/ 
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
doublehelixerCommented:
Another option would be to boot to a live linux cd like Ubuntu and copy the files onto your XP drive that way
0
 
Wes JonesIT DirectorAuthor Commented:
Thanks for the help.. unfortunately not working. (Haven't tried the Linux boot, I will as soon as I have a chance. )
For clarity, this is an XP machine with a Windows 7 external drive. The hidden folders that I need to access do not have a security tab and changing the ownership of the entire drive, which I can do, has no effect.
I have a hunch that although it is more work, the linux option may in fact be successful (although right now I wouldn't bet on it...)
I will try that at my earliest opportunity and let you know how it goes.
Thanks
wj
0
 
Wes JonesIT DirectorAuthor Commented:
Actually, the Linux approach didn't fare any better... used Ubuntu and even as root the Documents and Settings folder reports 0 files. Looks normal, appears to open, but shows nothing...
I may be missing some alternate approaches here, my Linux skills are pretty basic - if you have an approach I should try, let me know -

Thanks!
wj
0
 
LeeTutorretiredCommented:
Well, if you were using Windows 7, then as in Vista, the Documents and Settings is not really a folder; it is a pointer to the real user folder which is \Users\<username>\Documents
0
 
doublehelixerCommented:
Did you have encryption enabled on the drive (bitLocker)?
0
 
Wes JonesIT DirectorAuthor Commented:
No encryption - just a lack of information.. or knowledge <g>

Since Vista (which I avoided like the plague) 'Documents and Settings' has apparently been a virtual folder only accessible through the OS - XP doesn't understand it. What I needed was the data therein, now stored in Users\<username>\Documents...once I figured that out THEN the take ownership thing worked..  Essentially I was trying to change file access by changing properties on what amounts to a shortcut...

Thanks for the help, I would not have worked it out without the help from here..
wj

0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 3
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now