EIGRP Routing Issues, This is a hard one, Experts enter

I have 3 routers, each router has 2 pc's connected via cross over cable to each of its fast ethernet ports 1 and 2.

I am having EIGRP routing issues
I attached a network diagram so you can get a better picture of whats going on


Router HQ
-1 PC on Fa0/0
-1 PC on FA0/1
-Serial0/1 - Connected to Remote 1
-Serial0/0 - Connected to Remote 2

Remote 1
-1 PC on Fa0/0
-1 PC on FA0/1
-Serial0/1 Connected to HQ
Remote 2

-1 PC on Fa0/0
-1 PC on FA0/1
-Serial0/0 Connected to HQ




My problem is the following

both PCs at Remote 1 can ping Both PCs at HQ and at Remote 2
both PCs at Remote 2 can ping both PCs at Remote 1, but not at HQ
both PCs at HQ can ping both PCs at Remote 1, but not at Remote 2

So

Remote 1 -> HQ Ping sucesfull
Remote 1 -> Remote 2 ping sucesfull

Remote 2 - Remote 1 ping Sucesfull
Remote 2 - HQ ping "NOT" sucesfull

HQ - Remote 1 ping Sucesfull
HQ - Remote 2 pung "NOT" Sucesfull


all of my PCs gateways are correctly configured as I can ping their gateway router without a problem


These are my relevant router configs

===============HQ HQ HQ HQ HQ=========
interface Loopback0
 ip address 189.54.69.254 255.255.255.252
!
interface FastEthernet0/0
 ip address 192.168.158.1 255.255.255.128
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.158.129 255.255.255.192
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 192.168.159.101 255.255.255.252
 clock rate 64000
!
interface Serial0/1
 ip address 192.168.159.97 255.255.255.252
!
router eigrp 1
 network 192.168.156.0 0.0.3.255
 network 192.168.159.0
 network 192.168.158.0
 auto-summary

########
==================Remote 1===============

interface FastEthernet0/0
 ip address 192.168.159.65 255.255.255.224
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.159.1 255.255.255.192
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
!
interface Serial0/1
 ip address 192.168.159.98 255.255.255.252
 clock rate 64000
!
router eigrp 1
 network 192.168.159.96 0.0.0.3
 network 192.168.159.0
 auto-summary
##########
==================Remote 2============
interface FastEthernet0/0
 ip address 192.168.157.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.158.193 255.255.255.192
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 192.168.159.102 255.255.255.252
!
interface Serial0/1
 no ip address
 shutdown
!
router eigrp 1
 network 192.168.159.0
 network 192.168.157.0
 network 192.168.158.0
 network 192.168.156.0 0.0.3.255
 auto-summary
###########

1.png
14998702.png
John_T21Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

greg wardSystems EngineerCommented:
auto-summary

Please turn this off on hq router.
Also to check your routes are correct use
show ip route
 
Greg
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
naresh_kanneCommented:
THE PROBLEM MIGHT BE THE COMPLEX SUBNETTING SO TRY THE NETWORK WITH EACH DIFFERENT NETWORK SUBNETS YOUR PROBLEM MAY SOLVE .
0
GJHopkinsCommented:
as deepdraw said auto-summary is most likely the problem. When using variable length subnet masks its unlikely that you will want to summarize at a classful boundary.

When troubleshooting this sort of problem its often best to move away from the PC and check form the routers using extended pings. So for example can HQ ping remote 1 and remote 2 from its serial interface, its ethernet interfaces etc. If not check the routing table to see where the packet is being sent.



0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

HodepineCommented:
Just do the following on all your routers and it should work.:

router eigrp 1
no auto-summary

It is as they say a problem with auto-summarization. EIGRP behaves as a classful routing protocol before you use the "no auto-summary" command, and your mix of /24, /26 and /30-networks (which is Variable Length Subnet Masking or VLSM) won't work with a classful routing protocol.

0
nstamoulCommented:
router eigrp1
  no auto

You are done
0
John_T21Author Commented:
thanks for all your replies.. trying the no autosummary now.. will be back with results shortly
0
John_T21Author Commented:
Thank You.. took me a few minutes to figure out, but its working correctly now
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.