sys is undefined

silverlight content which calls wcf webservice does not load (at all) when deployed on web hosting. It works fine on local machine. On host, it doesn't load the silverlight content at all, and gives a javascript error saying sys is undefined.

It gets 404 errors if I look at fiddler, for webresource.axd and scriptresource.axd calls. I get 404s if I try to browse directly to the service. I get 405s if I try to add a reference to the service to a  project on the local machine.
NT AUTHORITY\NETWORK SERVICE was listed as a user for the local version of the database. I omitted that from the script when putting it on the host because I didn't have access rights to create it.
As I recall, it is needed for webservices to have access. Would this be causing the error i describe?
If there is an issue with getting this set up as a user on the shared host, would there be a way of configuring things so it's not necessary?
LVL 9
peterdunganAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rajeeshmcaCommented:
Hi peterdungan,

Try adding the EnableEventValidation = "false" property for the page directive
0
peterdunganAuthor Commented:
Adding the following to the web config handlers section appears to have fixed it; although I haven't tested it on the same machine where the bug occurred yet:
 
           <add name="Ajax" path="*.axd" verb="*" modules="IsapiModule"
scriptProcessor="C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll"
resourceType="Unspecified"
preCondition="classicMode,runtimeVersionv2.0,bitness32" />
0
peterdunganAuthor Commented:
I get a 405 error when I call the webservice from the Silverlight application.
Why is that?
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

rajeeshmcaCommented:
0
peterdunganAuthor Commented:
That link doesn't solve my problem unfortunately.

In the link, it says to check if the service is accessible in the browser. In my first post I mentioned that I get a 404 if I browse directly to it in the browser. It seems that the host isn't configured to handle svc calls? Would it be corrrect to ask them to run ServiceModelRef.exe?

Thanks
0
peterdunganAuthor Commented:
This was solved by my host. An isapi handler in needed to be defined in the web.config file.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Development

From novice to tech pro — start learning today.