Exchange 2003 Ent MapiSessions

Hi
I had a problem where i was getting the event id 9646 logged for a user and they were stopped from logging on.
Having read the knoweldge base article 830836 i created the key MaxObjsPerMapiSession becuase it did not appear under the location in HKLM.
Thing is  it has made performance on exchange really poor and now i think a bad add in may have caused the original issue on Outlook 2007 and i have removed that so now i want to sort the exchange performance.
Question is do i delete the key i added or do i change the value to the default 32?
Becuase the key did not exist before i had this problem i am leaning towards deleting it but i dont want to wreck exchange.
please help
kingcastleAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MailrootCommented:
Try to understand why does that Event ID 9646 appears in the Event Viewer.
Any client which opens Mapi Connections more than permitted you will have this Event id.
Now if you have read through the Article 830836, it clearly warns you about a significant performance affect on Exchange Server.
If you Delete that key MaxObjsPerMapiSession, it will go back to default, but you will start getting those events.
try troubleshoot with the Client see why it is opening Max Sessions and creating large Mapi Calls.
You can also try disabling the TCP Chimmney or Checksum offload on the NIC on Exchange So that the Server has no barrier while taking these calls.
http://support.microsoft.com/kb/912222

-Ethan
0
Shreedhar EtteCommented:
You can delete the key.
0
lone_wandererCommented:
If you post the event that you are getting it would be very helpful.
Check if you have http://support.microsoft.com/kb/950224 hotfix installed on the exchange server. Also check the NIC binding order.
 
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

MegaNuk3Commented:
what did you set the value to? 64 should be high enough for most users...

Is the user using Outlook 2007 and are they opening lots of additional mailboxes?
0
kingcastleAuthor Commented:
thats the weird thing the user is not opening any additional mailboxes or sending lots of mails. its only happening to one user and yes it is Outlook 2007 using cached mode.

i set the value to 50, i will however delete this key tonihgt and reboot.

cheers
0
MegaNuk3Commented:
Have they got any weird 3rd party add-ins installed in Outlook 2007 like an indexer that enables fast searching?

Normally when an application opens more than 32 sessions instead of reusing them it is an application issue not Exchange.

On his Outlook turn this option off:
On the Tools menu, click Account Settings.
Click the Exchange Server account, and then click Change.
Click More Settings.
On the Advanced tab, click to clear the Download shared folders (excludes mail folders) check box.
Click OK, click Next, and then click Finish.

so in future if he opens additional mailboxes they will not synch to his OST
0
MegaNuk3Commented:
Also when you say you set it to "50" you mean "50 decimal" and not 50 Hex, which is 80 in decimal?
0
MegaNuk3Commented:
Delete the key.
What 9646 event were you actually getting because by default Exchange has these values:
session = 32 (which is what I was talking about)
message = 250
attachment = 100

So if you changed the messages or attachments down to 50 then that would cause an issue...
0
kingcastleAuthor Commented:
i was getting the session i greater than 32 and the download fodlers is already turned off.
0
MegaNuk3Commented:
Have a look at:
http://support.microsoft.com/kb/830829/

Which talks about the values and increasing them by 100 at a time.
0
MegaNuk3Commented:
If you were getting the sessions one then you should look at this article, (which you probably already have seen) http://support.microsoft.com/kb/842022

The DWORD is called "Maximum Allowed Sessions Per User" which is under MsExchangeIS\ParametersSystem and is different to anything under MsExchangeIS\ParametersSystem\MaxObjsPerMapiSession  

So I am a bit confused as to what you actually set to 50...
0
kingcastleAuthor Commented:
prob set the wrong one then.
i will delete this key and see how we go.
i cant see anything on outlook 2007 that is causing this its really weird.

cheers
0
MegaNuk3Commented:
try Outlook /noextensions on that persons machine for the day and then if you don't get a 9646 event on the server then it is an Outlook add-in causing the issue
0
kingcastleAuthor Commented:
will do cheers
0
kingcastleAuthor Commented:
ok removed the key and my exchange performance went back to normal. but came in this mornign and the user is aagin disconnected and the event log is logging the same error, ah.....
0
MegaNuk3Commented:
Was the user running Outlook with /noextensions or not?

0
MegaNuk3Commented:
You can use TCPView on the exchange server to find and disconnect all their connections/sessions on MSExchangeIS, so they can use their mailbox again OR this MS tool (Microsoft Exchange Server User Monitor)can apparently do it too:

http://technet2.microsoft.com/windowsserver/en/library/db56b4d4-a351-40d5-b6b1-998e9f6f41c91033.mspx?mfr=true
0
kingcastleAuthor Commented:
sorry megaNuk i didnt try the /noextensions i will do that now and report back.


cheers
0
MegaNuk3Commented:
Also have a look in the registry on the server at this key:
HKLM\System\CurrentControlSet\Services\TcpIP\Parameters
Is there a EnableTCPChimney (DWORD)? Is it set to 0 or 1?

If it doesn't exist then I recommend installing this hotfix:
http://support.microsoft.com/?kbid=948496
0
kingcastleAuthor Commented:
it is set to 1
0
MegaNuk3Commented:
either set it 0 and reboot or install Q948496 because that is known to cause this issue.
0
MegaNuk3Commented:
I don't think /noextensions will allow him to access exchange because there are still 32 sessions open for him on the server, so you are either going to have to close those sessions manually or wait 2 hours for exchange to start closing them.

But to be honest,I think once you have installed Q948496 the problem shoud disappear
0
MegaNuk3Commented:
Also you can apparently disable the TCPIPChimney without a reboot by using this command:
Netsh int ip set chimney DISABLED

So run that and see what happens with your user...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Shreedhar EtteCommented:
Hi,

Run Exchange 2003 Best Practise Analyser tool on the server and fix the errors reported.

What is the OS version?

I hope this helps,
Shree
0
MegaNuk3Commented:
Thanks for the points.

Did "Netsh int ip set chimney DISABLED" resolve the 9646 event?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.