• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1083
  • Last Modified:

GPO deployed printers not appearing for certain users

Hi there,

I have a problem with a client currently.

I am trying to setup GPO to deploy their printers. They have an SBS 2003 R1 server which runs as the PDC and a 2003 R2 server which I'm using as the print server. The schema has been updated and in fact I can get this to work for certain users on a vista machine fine (both local admin and non local admin).

However the problem I have is that I have moved another user into this GPO and although GPRESULTS show the policy has been accepted the new printers do not appear in control panel -> printers.

I've tried gpupdate, gpupdate /force, gpupdate /sync, rebooted multiple times and I even installed RSAT tools and client side extension (even though i dont think i needed to bearing in mind it works with other users).

I'm completely lost.

Can anyone help? I hope so - pulling my hair out!!

Thanks in advance
  • 4
  • 2
3 Solutions
kacklandAuthor Commented:
Slight update.
Interestingly I added the user in question to the domain admin group and then the printers appeared on next login.

Any ideas where to look for this? Sounds like a permissions error to me. Could it be another policy in GP thats causing this issue?

Again thank in advance - 500 points up for grabs.
Malli BoppeCommented:
I think the user needs to be local admin on the machines.Can you change it and see if it works.
Is it happening for a particular set of worksations like all vista or 7 machines but no impacting windows xp.Then it could be user access control.Try disabling and see if it works.
How are you adding the printers is it through a script which maps the prints?
kacklandAuthor Commented:
Windows Vista and Windows 7 machines work fine.
What would be the best way to ensure all domain users are local administrators of all workstations?
I'm pretty sure my last attempt (last night) opened a whole new can of worms.

Thanks again
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

You have two options to deploy printers using GPO. One based on the computer and one based on the user.
What are the security filtering on the printer deployment GPO?  Is it for authenticated_users?

Check the application event log when the user that does not get the printers logs in to see if there is an explanation there.
kacklandAuthor Commented:
Managed to sort this one out ourselves.
Found that by moving pushprinterconnections.exe to the SYSVOL folder (the scripts folder within the folder) that it then worked for local admins and non local admins. I can only assume that there was a permissions problem regarding the folder that it was in previously.
kacklandAuthor Commented:
Is this ok?
Malli BoppeCommented:
Yeah fair enough
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now