Help with xcacls

I'm trying to script a batch file that will create a set of folders with specific permissions. Up to this point, i've been using cacls. I've recently had the request to deny delete permissions on one of these folders. I obviously cannot do that with cacls, so i need to use xcacls. I tried running xcacls on the command prompt and it basically told me that it doesn't know what program i'm talking about. So i downloaded xcacls from Microsoft that had an installer which when run, created a xcacls.vbs file. I have to run the from the actual folder that its in for it to recognize the program i need, and when i try to run it, i get an error message stating: "You are not using CScript for the scripting engine. Screen messages will be surpressed." So i tried running a basic test to modify permissions within the same file folder in a command prompt and that little window keeps on appearing and nothing changes.

What i'd like to do is have this batch file on a public server (Windows Server 2003) and allow about 5 people to run this file.

What do i need to do to each of their computers and the servers in order to get this to run correctly without an error message?
LVL 1
ciphronAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

khashayar01Commented:
have you tried running: "cscript <path to your xcacls>"
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ciphronAuthor Commented:
so in the batch file, i type:
cscript <path to xcacls.vbs> <filename> <permissions>
?
0
khashayar01Commented:
exactly, give that a shot.
0
ciphronAuthor Commented:
that works!
thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.