HOW TO SETUP an ethernet interface as backup 3g wan interface on cisco881 router

I need to attach a 3G Wireless bridge to an Ethernet interface on the Cisco Router 881 and configure that interface as backup to the FE WAN interface on the router.
Please help.
abassydoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

luc_roySystem AdminCommented:
So you only want to send traffic if the WAN goes down?

Assuming the bridge is configured and working properly you just need to add another route to that interface.

SPECIFIC ROUTES (used unless down)
ip route 202.148.224.0 255.255.255.128 e0
ip route 202.148.224.128 255.255.255.128 e1

BACKUP ROUTES
(used when one of the specifics are down)
ip route 202.148.224.0 255.255.255.0 e0
ip route 202.148.224.0 255.255.255.0 e1
Scenario 2: Using Cisco's Weight mechanism
ip route 202.148.224.0 255.255.255.0 e0
ip route 202.148.224.0 255.255.255.0 e1 250

Here is a great link that explains it in every scenario
http://www.inetdaemon.com/tutorials/internet/ip/routing/static/
0
abassydoAuthor Commented:
I need help to make the Failover interface FE1 works with ACL on the router as the FE4.


interface FastEthernet0
!
interface FastEthernet1
 description Backup Internet Connection via 3G - Failover
 switchport access vlan 999
 pppoe-client dial-pool-number 1
!
interface FastEthernet2
 shutdown
!
interface FastEthernet3
 shutdown
!
interface FastEthernet4
 description Internet Connection via [ISP], Ciruit Type:[Type], Circuit ID:[Circ
 backup interface FastEthernet1
 ip address 68.x.x.x 255.x.x.x
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
 pppoe-client dial-pool-number 1
!
interface Vlan1
 description Store_Network (LAN)
 ip address 10.x.x.x 255.255.255.x
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!
interface Vlan999
 ip address 172.16.x.x 255.255.255.0
!
interface Dialer0
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap
!
no ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 68.x.x.x
ip route 0.0.0.0 0.0.0.0 172.16.x.x 100
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip nat inside source list 100 interface FastEthernet4 overload
0
abassydoAuthor Commented:
I resolved the issue I was having setting up the Cisco Router 881 with an attached 3G Top Global box as Backup to the WAN FE4 interface on the router. Below is my final and wroking configuration:

Current configuration : 4631 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname HGYEG004
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 51200 warnings
no logging console
enable secret 5 $1$7rLW$iT9SarH37qUOR/42KrFlz0
enable password 7 0865494D1C0B44032B4B1C16233D2D24363227535643
!
no aaa new-model
clock timezone MST -7
clock summer-time MDT recurring
!
crypto pki trustpoint TP-self-signed-1601095320
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1601095320
 revocation-check none
 rsakeypair TP-self-signed-1601095320
!
!
ip source-route
!
!
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool sdm-pool
   import all
   network 10.10.10.0 255.255.x.x
   default-router 10.10.10.1
   lease 0 2
!
!
ip cef
no ip domain lookup
ip domain name hudsongroup.com
ip name-server 4.2.2.2
ip name-server 4.2.2.3
!
no ipv6 cef
!
multilink bundle-name authenticated
vpdn enable
!
!
!
object-group service AllowedPorts
 description Outbound allowed ports
 tcp eq 443
 tcp eq www
!
object-group network LANDevices
 range 10.10.10.2 10.10.10.6
!
username hgedadmin privilege 15 password 7 015755074E19471B18
!
!
!
archive
 log config
  hidekeys
!
!
ip ssh version 2
!
!
!
interface FastEthernet0
!
interface FastEthernet1
 description Backup Internet Connection via 3G - Failover
 switchport access vlan 999
 pppoe-client dial-pool-number 1
!
interface FastEthernet2
 shutdown
!
interface FastEthernet3
 shutdown
!
interface FastEthernet4
 description Internet Connection via [ISP], Ciruit Type:[Type], Circuit ID:[Circ

 backup interface FastEthernet1
 ip address 68.x.x.x 255.255.x.x
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface Vlan1
 description Store_Network (LAN)
 ip address 10.10.10.1 255.255.x.x
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!
interface Vlan999
 ip address 172.16.0.2 255.255.x.x
 ip nat outside
 ip virtual-reassembly
!
no ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 68.x.x.x
ip route 0.0.0.0 0.0.0.0 172.16.0.1 100
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip nat inside source route-map backup interface Vlan999 overload
ip nat inside source route-map primary interface FastEthernet4 overload
!
access-list 1 remark CCP_ACL Category=2
access-list 1 permit 10.10.10.0 0.0.0.7
access-list 23 permit 10.10.10.0 0.0.0.7
access-list 100 permit tcp 10.10.10.0 0.0.0.7 host 69.x.x.x eq 990
access-list 100 permit tcp 10.10.10.0 0.0.0.7 host 69.x.x.x eq ftp
access-list 100 permit tcp 10.10.10.0 0.0.0.7 host 70.x.x.x eq 443
access-list 100 permit tcp 10.10.10.0 0.0.0.7 host 70.x.x.x eq 443
access-list 100 permit tcp 10.10.10.0 0.0.0.7 host 70.x.x.x eq 443
access-list 100 permit tcp 10.10.10.0 0.0.0.7 host 70.x.x.x eq 443
access-list 100 permit tcp 10.10.10.0 0.0.0.7 host 70.x.x.x eq 443
access-list 100 permit udp 10.10.10.0 0.0.0.7 any eq domain
access-list 100 deny   ip any any
dialer-list 1 protocol ip permit
snmp-server community xxxxxxx RO
snmp-server community xxxxxxxxx RW
snmp-server location MY town, NYC Store
snmp-server contact xxxx YYYY
no cdp run

!
!
!
!
route-map backup permit 1
 match ip address 100
 match interface Vlan999
!
route-map primary permit 1
 match ip address 100
 match interface FastEthernet4
!
!
control-plane
!
!
l
scheduler max-task-time 5000
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Hardware

From novice to tech pro — start learning today.