ICMP Malfunction

Windows 2003 SBS SP1 PDC running Exchange 2003, BES 4.1.4, Remote Access, DNS and DHCP
ICMP seems to be broken when RSS services get enabled. I can toggle being able to ping and not being able to ping by starting and stopping the servcies. We rely on ICMP for our management software and need to fix it asap. We had a problem with Remote Access Services and tracked that down to a port 1723 issue between Remote Access VPN and BES services I made the BES services dependent on the Remote Access Services and this resolved that issue. I was hoping that this would also solve the ICMP problem but it did not. We cannot Ping the server via hostname or IP with RSS enabled but the server can ping itself. Any help would be appreciated.
aldudukAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rob WilliamsCommented:
What are you referring to by RSS? Receive Side Scaling, or Routing and Remote Access service (RRAS)?

RRAS:
If you cannot ping the server by IP with RRAS enabled, I would suspect NAT is enabled within RRAS. It shouldn't be.
If you cannot ping the sever by name with RRAS enabled, verify in the DNS management console, under server properties, on the interfaces tab, that only the LAN IP of the server (not the VPN IP) is checked.

RSS:
Receive Side Scaling is known to cause problems and should be disabled.

You also mention SBS SP1. SP2 addresses some networking isssues, you may wish to install it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
aldudukAuthor Commented:
Sorry for the confusion, RRAS and yes NAT was enabled. I've reset the services with it not enabled and am testing it as we speak.
0
Rob WilliamsCommented:
Sounds good.
The default RRAS wizard enables NAT. If you use the VPN, with SBS, the best option is to use the "configure remote access" wizard, as per:
http://www.lan-2-wan.com/SBS-VPN-instr.htm
0
aldudukAuthor Commented:
This did work, the only side effect that I've seen is that the BES Services stopped and had to be restarted.  But this we can live with. Thank you very much for your solution it worked very well.
0
Rob WilliamsCommented:
Thanks alduduk. Glad to hear it worked for you. Originally BES was not supported on SBS but it would work with a few tweaks. I wonder if this is the case with your server. The newer versions work fine and are supported.
Cheers!
--Rob
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Protocols

From novice to tech pro — start learning today.