Inbound rate limiting on Cisco 3750 not working

Dear Cisco Guru,

I am trying to do rate limiting on our cisco 3750 but it does not seems to work. No packets are catched when using: show policy-map interface Gi 1/0/5.

Please find my configuration bellow:



Current configuration : 5289 bytes
!
version 12.2
!
mls qos
!
!
class-map match-any VOIP
  match ip dscp ef
class-map match-any VMWARE
  match access-group 101
class-map match-any AS400
  match access-group 100
!
!
policy-map QoS_FO
  class VOIP
   set dscp ef
    police 1000000 12500 exceed-action drop
  class AS400
   set dscp af41
    police 6000000 75000 exceed-action drop
  class VMWARE
   set dscp af31
    police 38000000 475000 exceed-action drop
  class class-default
   set dscp default
    police 3000000 37500 exceed-action drop
!
!
!
interface GigabitEthernet1/0/5
 description Fibre Optique 50
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10,40
 switchport mode trunk
 service-policy input QoS_FO
!
!
access-list 100 remark AS400
access-list 100 permit ip host X.X.X.X any
access-list 100 permit ip host X.X.X.X any
access-list 101 remark VMWARE
access-list 101 permit ip host X.X.X.X any
access-list 101 permit ip host X.X.X.X any
access-list 101 permit ip host X.X.X.X any

============================================

BUCAT3711#show policy-map interface gigabitEthernet 1/0/5
 GigabitEthernet1/0/5

  Service-policy input: QoS_FO

    Class-map: VOIP (match-any)
      0 packets, 0 bytes
       offered rate 0 bps, drop rate 0 bps
      Match: ip dscp ef (46)
        0 packets, 0 bytes
         rate 0 bps

    Class-map: AS400 (match-any)
      0 packets, 0 bytes
       offered rate 0 bps, drop rate 0 bps
      Match: access-group 100
        0 packets, 0 bytes
         rate 0 bps

    Class-map: VMWARE (match-any)
      0 packets, 0 bytes
       offered rate 0 bps, drop rate 0 bps
      Match: access-group 101
        0 packets, 0 bytes
         rate 0 bps

    Class-map: class-default (match-any)
      0 packets, 0 bytes
       offered rate 0 bps, drop rate 0 bps
      Match: any
        0 packets, 0 bytes
         rate 0 bps


There is not even traffic catch by the class-default, what the hell is going on ?
Thanks a lot for any help you could give me.
mikael42Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kavlinsCommented:
Looks right to me, Is the truck going to Router or Switch ? This is a core switch right? any distribution layer or access switch after it?
0
mikael42Author Commented:
Dear Kavlins,

Thanks for your anwser, this port (gigabitEthernet 1/0/5) is connected to the telco switch providing us a optical fiber between 2 remote sites. To be more precise, I would like to do QoS on this optical link between our 2 remotes site but I don't have any administrative access to the telco switches.
0
Alex BaharCommented:
LOL I was banging my head for the same issue 2 months ago. Now go to this link and read the fine print
http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.1_11_ax/command/reference/cli2.html#wp2784632
show policy-map
Note Though visible in the command-line help string, the interface keyword is not supported, and the statistics shown in the display should be ignored.  

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.