ESXi Install on IDE

I have a system that has an ide controller with compact flash.

If I try to install ESXi 4.0 to it with the compact flash installed into the controller, it reports that it cant find a device to install too. Suprise right?

So I got a USB card reader, installed the compact flash into the reader and was able to sucessfully install ESXi 4.0 to it.
It will even boot up just fine in the card reader. But this is not my final goal.

I want it to boot up via the compact flash slot on the controller.

So I disconnect the card reader - place compact flash into controller.
Booting up ESXi gives an error that it cant find boot partition.
so i pushed the ALT-F1 typed in unsupported and was able to get in.

Went into /var/log/sysboot.log and saw
sysboot: Invalid Primary Boot bank Detected: /vmfs/volumes/386a41e4-xxxx-xxx
sysboot: unable to detect USB boot partition
sysboot: Failed to find boot partition
sysboot: Executing 'esxcfg-init --alert Error: Failed to find boot partition'

I went inside /vmfs/volumes and there was nothing there.
fdisk doesnt show any partitions.

How can I boot this ESXi machine using the compact flash installed inside the on-baord ide controller.

Is there any special commands I can type or config files I can edit to make it work?

LVL 1
bntechAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jakethecatukCommented:
The chances of getting that to work will be slim unless the IDE controller is listed on the VMWare HCL or it can emulate a controller on the HCL.  What make of IDE controller is it?

The reason it worked via the USB Card reader is that ESXi will support booting of USB.

If you are keen to install of compact flash then look for a compact flash reader that connects to an internal USB header in the computer.

BTW - why the desperate need to use compact flash?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bntechAuthor Commented:
tried a solution by editing the targetfilter.py, but it did not see disk, went ahead and put it on the local drive, not compact flash

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.