BES Express 5.0 error 10000

Just installed Blackberry Enterpise Server Express 5.0.  All services are running. When I setup a new users and click "create a user with generated activation password" everything looks ok but the last line says "One or more errors occurred. BlackBerry enabled users were not created."  In the event log, Event ID 10000 is logged for Blackberry Mail Store Service, with this info: Failed to mail Subject BlackBerry activation password to email@domain.com.

Nothing I can find addresses this specific message.  This is an Exchange 2010 Server running on Server 2008R2.

Any ideas?
LVL 1
digital0g1cAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

megs28Commented:
If you setup an Outlook profile, are you able to email the users and outside the company?.  Double check all your BES service account permissions, and DNS configuration.  Be careful of .local addresses, as well as any internal MX records setup in the domain.

Anything in the BES logs?
0
digital0g1cAuthor Commented:
I forgot it had its own log...  Anyway, thanks!  Looking at he log I found the issue has to do with the offline address book not existing.  Changed the registry key mentioned in the manual and it works now!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bruceleroyCommented:
Can you post some more information on this?  I'm seeing the exact same issue, but can't seem to find the information you mentioned about changing the registry key.
0
digital0g1cAuthor Commented:
you need to install this:  http://www.microsoft.com/downloads/details.aspx?FamilyID=e17e7f31-079a-43a9-bff2-0a110307611e&displaylang=en on the server before you can make the registry changes.  This allows the BIS server to have MAPI connections to the exchange server for accessing e-mail for the end users.
0
WestJetCommented:
Hi There, What regestry change did you make?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.