exchange 2007 defrag mailbox database

hi,

when I running the defragment, it stop and show the error like that, any idea for that?

thanks
error.JPG
Simon ChenNetwork AdministratorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sekhar_kiitCommented:
Is the mailbox store dismounted? I feel you have to do that first before running defrag.

Cheers,
Sekhar
0
Simon ChenNetwork AdministratorAuthor Commented:
yes, it is already dismounted
0
sekhar_kiitCommented:
Check if any other process is running, mostly backup. Restart the information store service if possible. It will free up all the connections.

Cheers,
Sekhar
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

Rick FeeMessaging Engineer - Disaster Recovery EngineerCommented:
Check your path...I see D:\Exchange Server\MailboxFirst Storage Group....

The default and my guess the proper path is:   D:\Exchange Server\Mailbox\First Storage Group...
0
sekhar_kiitCommented:
Yes Endurekona is right. I also feel so.

Cheers,
Sekhar
0
Simon ChenNetwork AdministratorAuthor Commented:
I have restart the whole server and stop the backup, but still the same issue
0
Simon ChenNetwork AdministratorAuthor Commented:
we  just moved the database location , but I am very sure that is the right folder path, when I create it I mixed the name together.
0
Rick FeeMessaging Engineer - Disaster Recovery EngineerCommented:
Double check the path...as it appears the path does not appear to be correct the message in your image indicates Cannot access File so make sure you have the path.   If you are still getting the error take another screen shot.  
0
Simon ChenNetwork AdministratorAuthor Commented:
I know the path seems stranger ,but I am very sure my path is:D:\Exchange Server\MailboxFirst Storage Group\Mailbox Database.edb, so don't focus on here, it's not the wrong path
error.JPG
error1.JPG
0
Rick FeeMessaging Engineer - Disaster Recovery EngineerCommented:
I see Exchange does report that it believes the path is D:\Exchange Server\MailboxFirst Storage Group\Mailbox Database.edb....but can you confirm with Explorer?      Maybe Exchange 2010 has had an issue and not reporting the path correctly.   The problem is that your eseutil screen shot says cannot access file.... so the path is wrong or the edb does not exist so you will have to restore.

So if you copy this line:   'D:\Exchange Server\MailboxFirst Storage Group\"    and on your Exchange server open a run line paste it.      Does it open the folder with the edb or do you get location not found....?  
0
joenswCommented:
hi
 did you enable  the Local Continuous Replication (LCR)
0
Simon ChenNetwork AdministratorAuthor Commented:
I found the reason, even My account is administrators, but still need to use administrator to login to run
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.