• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1186
  • Last Modified:

Joomla 1.5.15 SEO friendly URL problem

I migrated joomla 1.0 to joomla 1.5.15

Everything else is working fine, the only problem i faced is SEO friendly URL's

I uploaded the htaccess.txt file to root and renamed to .htaccess
I also changes Global Configuration-> SEO Settings -> Search Engine Friendly URLs, Use Apache mod_rewrite to YES
But still not working

URL's are working like this :-

http://sitename.com/component/content/?task=view

What to do ???
0
rajanibajpai
Asked:
rajanibajpai
  • 12
  • 11
  • 2
1 Solution
 
Avinash ZalaWeb ExpertCommented:
check this for URL rewrite in joomla 1.5

http://www.joomace.net/joomla-extensions/acesef

Hope this helps.
Addy
0
 
rajanibajpaiAuthor Commented:
Hi Addy

Still not working..... i installed component and configured SEF urls in this
No help

Thanks for reply... plz reply
0
 
Avinash ZalaWeb ExpertCommented:
what u want to do?
I have just used that component last night and its working for me very fine.

Can you please explain the error are your requirements?

Hope this make sense.
Addy
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
rajanibajpaiAuthor Commented:
Actually:-

I enabled SEO  from Global Configuration

But my urls are not working as seo friendly

All URL's are like this now:-  
http://sitename.com/component/content/?task=view

showing the error "The page cannot be found" on visit

Hope u got it
0
 
Avinash ZalaWeb ExpertCommented:
You need to enable only first two option to get this component work.

Hope this helps.
Addy
0
 
rajanibajpaiAuthor Commented:
I migrated joomla 1.0 to joomla 1.5.15
May be this is the reason...have no idea
0
 
Avinash ZalaWeb ExpertCommented:
May be... :-(
0
 
rajanibajpaiAuthor Commented:
Ok..
Can u tell me how to make use of this compopnent
I mean how to configure it so that we can convert all non-seo urls to SEF urls ?
0
 
Avinash ZalaWeb ExpertCommented:
check the attached image for some explanation of the components.

This is the snap of the dashboard of that component.


Hope this helps.
Addy
aceSef.png
0
 
rajanibajpaiAuthor Commented:
But SEF URLs did not create default links

Why?
0
 
Avinash ZalaWeb ExpertCommented:
try to create new links on that page  and you will get all links generated.

Please try this.

Thanks
Addy
0
 
rajanibajpaiAuthor Commented:
Added three urls
Still the same
And not changing urls

chk attachment of snapshot
Doc1.doc
0
 
Avinash ZalaWeb ExpertCommented:
Now click on the link under Real URL Tab, you can edit the link url at that stage.

Hope this helps.
Addy
0
 
rajanibajpaiAuthor Commented:
I used that
I edited them

But the problem is that, on my website all the urls are like this:-

http://sitename.com/component/content/?task=view

non of them changed

How to change them?
0
 
rajanibajpaiAuthor Commented:
menu are showing links like this:-
http://sitename.com/component/content/?task=view
0
 
Avinash ZalaWeb ExpertCommented:
have u created a custom view for the site or have you edited the core code of the joomla?

Addy.
0
 
rajanibajpaiAuthor Commented:
have created a custom view for the site

But it was old version on joomla
Just copied template of old version
0
 
Avinash ZalaWeb ExpertCommented:
so Finally got it, :-)

You don't have that view in newer version of that joomla.
That's why this problem is occurring.

Hope this make sense.
Addy.
0
 
rajanibajpaiAuthor Commented:
any other way to solve this problem?

The template is not easy to work upon

0
 
Avinash ZalaWeb ExpertCommented:
create same view in joomla 1.5 :-)

Hope this helps
Addy
0
 
rajanibajpaiAuthor Commented:
Its not easy task the template is so complicated
actually the employee who worked on this is not available now
and i have to work on this


any ways
thanks for ur help and if u find any solution plz let me know asap
0
 
Avinash ZalaWeb ExpertCommented:
ok dear sure :-)

Addy
0
 
Avinash ZalaWeb ExpertCommented:
was my comments works for you???


Addy
0
 
kumaranmcaCommented:
Hi,,

Refer the below url...

If you have Joomla installed in a folder (www.site.com/joomla) you will need to edit the RewriteBase line. It should read RewriteBase /joomla

Refer

http://www.mambodemo.com/joomla_1.0/enable_sef_urls.html

http://www.solarenergyhost.com/content/view/184/203/
0
 
kumaranmcaCommented:
Also, refer the below url..its resolve your problem.

http://www.teachmejoomla.net/joomla-mambo-tutorials-and-howtos/general-questions/how-to-enable-seo-on-joomla.html

"Step 1: check SEF URLs requirements:

There are a few requirements for SEF URLs to work properly(the other SEO configuration options work regardless you have SEF URLs enabled or disabled):
You need to run the Apache Web server.
You need mod_rewrite module on apache. Most hosting companies have that module installed.
Furthermore, you need Apache configuration to allow .htaccess files.

You can easily check your Apache configuration (among other system settings) by going to System->System information and selecting the php info tab in your Joomla administration backend.
There's an "Apache" section and a "loaded modules" subsection there. mod_rewrite should be listed among those modules.

If all went well, you're ready for the next step."
0

Featured Post

The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

  • 12
  • 11
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now