Goldmine Sync as a Service

Within goldmine we can use the GoldSync Administration Center to install GoldSync as a service.  Doing so creates the service in the services.msc listing, and the service starts just fine.

The problem is that this windows service called "GoldSync Service" isn't listening on port 5993 as it's supposed to be doing.  Actually, when I run Sysinternals Process Explorer, the gmw.exe service details on the TCP_IP tab doesn't list that it's listening at all.

From within Goldmine, I can run a process that is called by explorer.exe to open the port and listen, and I can see in the sysinternals process explorer where this one will open the port, but the problem is we want the service to always be listing and to auto start with a server reboot.

As it's setup right now - a Admin has to manually login to the Goldmine application on the server, and manually start the process.  Thoretically the windows service should be doing the same thing regardless of the application itself running.

I've tried removing AV softwarae (symantec endpoint protection with only AV protection install, no network security stuff) and it still wouldn't work.

Any thoughts on why this windows service isn't listening on the port as it should be doing?
gmw-process-started-inside-goldm.JPG
gmw-windows-service.JPG
Mike4CCMAsked:
Who is Participating?
 
Mike4CCMConnect With a Mentor Author Commented:
I fixed my own problem, after dealing with Frontrange directly for over a week (year actually, but week this last time) I found that it was a simple check box option that the first level of support should have discovered within just a few minutes.  After sessions with Symantec, Microsoft and going through MANY technicians at FrontRange I was relieved to get this fixed but a bit ticked it was something so simple.

Within GoldSync Administration Center, if you right click on the "IP to IP/Network: Accept incoming remote connection" and choose "Properties" you will enter the "Welcome to the Process Wizard".

From there, click next, then next again.

On this window, you have a check box at the top of the window that is labeled as follows:
"Start this sync process automatically if the GoldSync Agent detects the current time to be in the active period defined below.  This feature requires the GoldSync Agent to be running."

If you check that box, click finish.  Close Goldmine, then stop and restart your system GoldSync service the port should successfully open.
goldsync-works-now.JPG
0
 
GMGeniusCommented:
Can you confirm the GoldMine version?

Is it Enterprise?
0
 
GMGeniusCommented:
This is why i asked the version , you stated GoldMine Enterprise in your tags and I would of suggested excatly this.

Glad you have it sorted
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
Mike4CCMAuthor Commented:
This was a difficult issue and I ended up resolving it on my own, does that mean I get the points?
0
 
QlemoDeveloperCommented:
No, you can't get points for your own question. But the points will be refunded, and the question remains visible for other seekers.
0
 
QlemoDeveloperCommented:
Obviously that was an errornous accept - see my previous recommendation. I have requested attention already to change that.
0
All Courses

From novice to tech pro — start learning today.