Outlook 2007 "Connecting to sites"

I just setup SBS 2008 server.  One the workstations we are using Win 7 with Outlook 2007.  When we open Exchange we get "Connecting to sites" and it asks for username and password.  I put in the username and password and it doesn't work.  After I hit cancel it shows "Needs Password"' in the bottom right hand corner of Outlook.  When I click on "Type Exchange Password to Connect" it changes to "Connected to Microsoft Exchange".

Also, when I hit Send/Receive I get the following
Task "Microsoft Exchange" reported error (0x8004010F) : "The operation failed. An object cannot be found."  
This is the same error that I get on another SBS 2008.  I can't seem to make it go away.
RosspopeAsked:
Who is Participating?
 
chops_ukConnect With a Mentor Commented:
OK.
Check out my previous post's other solutions (from the good EE article linked there).
0
 
chops_ukCommented:
Looks like the offline address book problem.
Try the MS solutions:
http://support.microsoft.com/kb/905813
0
 
RosspopeAuthor Commented:
I've done this already

Exchange Server 2007
In Exchange Management Console, expand Server Configuration, and then click Mailbox.
In the Database Management window, right-click Properties on the mailbox store.
Click the Client Settings tab, click Browse, and then click the appropriate offline address book.
Click OK two times.
0
Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

 
chops_ukCommented:
hmm.. are you using domain\username as the username?
0
 
RosspopeAuthor Commented:
yes

It shouldn't ask for password for sites though... I am only using Outlook 2007.  It must have something to do with SBS server...?

Also, there is nothing in the RSS feeds
0
 
chops_ukCommented:
I've had the problem with missing autodiscover. DNS entry before, but it sounds like you're local.. although if you've got RPC / Connect to Microsoft Exchange using HTTP enabled whilst using internally then this could be an answer.
0
 
RosspopeAuthor Commented:
Not using RPC over HTTP
0
 
RosspopeAuthor Commented:
@chops_uk The following from the link worked for the connecting to sites problem.  Still having the problem with 0x8004010F...

------------------------------------------
Kernel authentication Mode

If you have all the above configured and you are still experiencing problems then the following procedure will more than likely fix it for you. It has been working a lot for me lately and also for people asking questions on Experts Exchange.

In Internet Information Services (IIS) Manager locate the Exchange virtual directories, if you are using Small Business Server 2008 these will be under the SBS Web Applications website, if you are not using SBS then they will be under the Default Website.

The virtual Directories you are looking for are:
    * Autodiscover
    * EWS
    * RPC
    * OAB
------------------------------------

0
 
RosspopeAuthor Commented:
so for their email, I haven't setup their email domain yet because we are waiting on the ISP to give us a static IP address.  So at the moment their emails are all user@domain.local
I have tried to repoint to the offline address book, rebuild it, etc. and still no go.
0
All Courses

From novice to tech pro — start learning today.