TrixboxCE dropping external incoming calls after exactly 15mins everytime

I started having problems with my external incoming calls.  I am able to route/answer all calls coming in and talk for exactly 15mins and then they drop.  All of my outbound calls to external numbers work just fine for as long as I want.  

I am using a SIP line from Quantum Voice which I haven't had any problem with since.  Not sure if it is a problem with my trixbox or a problem with my SIP Provider.  

Here is my User Details under Incoming Settings within the Trunk setup page of Trixbox CE.

   canreinvite=no
   context=from-trunk
   fromuser=*SIP NUMBER*
   insecure=very
   qualify=no
   secret=*PASSWORD*
   type=peer
   username=*SIP NUMBER*

If looking at the Peer Details will help let me know
rromanjrAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jfaubiontxCommented:
It is a problem with NAT. The ARP cache that keeps the information about your connection is being cleared after 15 minutes of inactivity. In your phones configuration you should have an option to send NAT keep alive packets. Enable this and you should fix the problem.
0
rromanjrAuthor Commented:
I double checked my GrandStream 2010 series phone and I already have that setting enable.  I also have an cisco wireless g sip phone that does the same thing.  

I have a Sonicwall Firewall in place...it there be a problem with the arp setting within it.
0
jfaubiontxCommented:
ls the call actually dropping or are you just losing the audio and hanging up?
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

rromanjrAuthor Commented:
call is dropping...I get a off hook beeping on my Grandstream phone and the Call Logs within trixbox show exactly 15 mins give or take a few secs
0
rromanjrAuthor Commented:
can I start a debug on all calls to just one extension...if so, what command should I type in?
0
jfaubiontxCommented:
Yes. You can enter "sip set debug peer <ext>" without the quotes and with the <ext> being the externsion number of the phone to watch.
0
rromanjrAuthor Commented:
This is what appears when the line drops when using sip debug on that ext.

<------------->
trixbox1*CLI>
trixbox1*CLI>
trixbox1*CLI>
    -- Executing [h@macro-dial:1] Macro("SIP/QuantumVoice-00000000", "hangupcall") in new stack
    -- Executing [s@macro-hangupcall:1] GotoIf("SIP/QuantumVoice-00000000", "1?skiprg") in new stack
    -- Goto (macro-hangupcall,s,4)
    -- Executing [s@macro-hangupcall:4] GotoIf("SIP/QuantumVoice-00000000", "1?skipblkvm") in new stack
    -- Goto (macro-hangupcall,s,7)
    -- Executing [s@macro-hangupcall:7] GotoIf("SIP/QuantumVoice-00000000", "1?theend") in new stack
    -- Goto (macro-hangupcall,s,9)
    -- Executing [s@macro-hangupcall:9] Hangup("SIP/QuantumVoice-00000000", "") in new stack
  == Spawn extension (macro-hangupcall, s, 9) exited non-zero on 'SIP/QuantumVoice-00000000' in macro 'hangupcall'
  == Spawn extension (macro-dial, h, 1) exited non-zero on 'SIP/QuantumVoice-00000000'
Scheduling destruction of SIP dialog '4348c93531eca5bd145994b24df2b5d2@10.0.0.25' in 6400 ms (Method: INVITE)
set_destination: Parsing  for address/port to send to
set_destination: set destination to 10.0.0.26, port 5060
Reliably Transmitting (NAT) to 10.0.0.26:5060:
BYE sip:401@10.0.0.26:5060;transport=udp SIP/2.0
Via: SIP/2.0/UDP 10.0.0.25:5060;branch=z9hG4bK4513a470;rport
ax-Forwards: 70
From: "Roman Roger" ;tag=as58faf25d
To: ;tag=15c5559786b7e4c7
Call-ID: 4348c93531eca5bd145994b24df2b5d2@10.0.0.25
CSeq: 103 BYE
User-Agent: Asterisk PBX 1.6.0.22-samy-r60
X-Asterisk-HangupCause: Normal Clearing
X-Asterisk-HangupCauseCode: 16
Content-Length: 0
0
rromanjrAuthor Commented:
what is --  X-Asterisk-HangupCause: Normal Clearing  and X-Asterisk-HangupCauseCode: 16
0
bwilks99Commented:
Hi, Here are two links that may help as they solved a 10 minute drop for me on asterisk 1.4. In my case the provider made a change on their end that changed the session timers/RE-INVITE function.

If it is not a nat problem look at the invite SIP 401 error. Try canreinvite=yes or look into why the invite exchange is going wrong.

http://www.experts-exchange.com/Networking/Telecommunications/IP_Telephony/Asterisk_/Q_25482222.html
http://forums.whirlpool.net.au/forum-replies.cfm?t=1235239&p=6#r113
http://forums.whirlpool.net.au/forum-replies.cfm?t=1235239&r=21511050#r21511050

0
jfaubiontxCommented:
The Hangup Cause code 16 is a normal clearing. I suspect your system received the hangup message from the provider. I don't believe this is a NAT issue after all. If it were a NAT issue, the audio would drop but the call would stay up. A session timer is likely the culprit here.

A sip debug on the trunk,  "sip set debug peer QuantumVoice" should tell us if the provider sent the message. You could try adding the following to your peer details.

session-timers=refuse
session-expires=180
session-minse=90
session-refresher=uas

0
rromanjrAuthor Commented:
Sorry for the Delayed response....had another issue I had to take care off first.  Here is my sip set debug peer QuantumVoice

I replaced my cell number, WAN IP, and SIP Number with descriptions.  

Here is another thought I came across.  At 15 mins the SIP Phone gets the phone off hook beep and the call is terminated.  The weird thing is that the Cell phones used to make the calls in with continue to time the call until I end the call on the cell phone.  I have tried other cell phones and other SIP phones with the same results.

I attached a print out of the log file from putty of the 15 min call from my cell phone to the SIP phone at my office.  Sorry for how long it is.  

Let me know if you find anything out.
TBox-QV-Debug.log
0
jfaubiontxCommented:
From what I see here, the call had three challenges which were responded to and the fourth received a 404 not found. These reinvites are used to reset the session timers. Try adding "session-timers=refuse" to your peer details. If this helps you may need to contact QuantumVoice as it is probably related to a session timer on their end.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rromanjrAuthor Commented:
It turns out that Quantum Voice changed their peer settings with out informing me....i just happen to see a post on their forum about new trixboxce peer settings.  somehow they differ from asterisk settings.
0
jfaubiontxCommented:
I find a lot of providers that have old information, often related to an older version of Asterisk on their websites. As newer versions of Asterisk come out, you may see changes in the settings.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
IP Telephony

From novice to tech pro — start learning today.