Publish website through ISA 2006

Hi there,

I've been trying to publish a webserver through ISA 2006. But I'm very close to giving up now.

I've done this before, but I can't seem to make it work now.

The website can be published on any other port except port 80.

I have OWA, SMTP, POP3 running on the same network , and are published accordingly and working as configured.

When I telnet from an external computer onto my external IP, I don't get Connecting..
but I get a blackbox which doesnt respond to commands like GET

Any help on this would be really appreciated
ArunRaveendranAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

aisaudaliteCommented:
Do you have a listener for port 80? Do you have IIS or another Webserver installed on that machine already using port 80? Can you post more details about your publishing rule?

Thank you.
0
ArunRaveendranAuthor Commented:
Yes I do have a listener on port 80
standard HTTP listener
Networks: External
Port(HTTP):80
Port(HTTPS):Disabled
Authentication Methods:No Authentication
Always Authenticate:No

Publishing rule details
From:Anywhere
To: Published Site: backup
      Computer Name: 192.168.20.1
      Forward original header - Checked
     Requests appear to come from original client-radio button selected
 Listener: HTTP
Public Name: www.domain.com.bh
Authentication: No delegation, and client cant authenticate directly.
bridging webserver redirect HTTP to port 80  
users:all users

there is IIS installed on the machine. default web site on port 8080
Link Translation is applied.
0
ArunRaveendranAuthor Commented:
edit to previous post.
IIS default web site on port 8081
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

aisaudaliteCommented:
Hi,

thank you for your additional information.
Is the www.domain.com.bh alias assigned to port 80 in server 192.168.20.1?
Thanks.

0
ArunRaveendranAuthor Commented:
Our internal domain is called domain.local
I've set up an internal zone called domain.com.bh
and www.domain.com.bh points to 192.168.20.1
How do you assign a port to domain name alias?
0
aisaudaliteCommented:
Hi,

sorry, I was talking about the web server, not DNS.

I need some information to help you:

Web Server where the website you want to publish is hosted : IIS, Apache, other?
Internal IP of the Web Server:
Port where the site is published:
FQDN of Public Name of the site:
FQDN of the Internal Name of the site:

Thank you very much.


0
ArunRaveendranAuthor Commented:
Web Server is hosted on IIS
Internal IP: 192.168.20.1
Port:80
FQDN of Public name: www.domain.com.bh
FQDN of Internal site: backup.domain.local

thanks in advance
0
aisaudaliteCommented:
Hi,

based on your publishing rule I think that the best option is to add a host header to your web site. It seems the issue here is that ISA is forwarding the original header "www.domain.com.bh" which is not recognized as a published site by IIS. Adding that host header (basically an alias for a website) you should have the site immediately available on the Internet.

Since I don't know which version of IIS you're running, please find below the instructions for each IIS version:

IIS 6:

To assign multiple host header names to a single Web site:

1. In  IIS Manager, expand the local computer, click the Web Sites  folder, right-click the Web site for which you want to assign a host  header name, and then click Properties.
2. Click  the Web Site tab.
3. In  the IP Addresslist, select the IP address that you want assigned  to this Web site.
4. Click Advanced.
5. Under  Multiple identities for this Web Site, select the IP address,  and then click Edit.
6. In  the Host Header Value box, type the host header name (for  example, www.contoso.com).
7. Click  OK twice.

IIS 7:

http://technet.microsoft.com/en-us/library/cc753195%28WS.10%29.aspx

Hope that helps,

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ArunRaveendranAuthor Commented:
Thanks for the tip. This helped in the configuration though.

I pinpointed the problem to be with my router.
The router was accepting all connections but on port 80 for some reason, even though the default server under NAT was set as my ISA server. I upgraded the firmware on the router and setup the port forwarding and the website started working.

Your help was invaluable

Many Thanks
0
ArunRaveendranAuthor Commented:
Edit to comment:

Thanks for the tip. This helped in the configuration though.

I pinpointed the problem to be with my router.
The router was accepting all connections but NOT on port 80 for some reason, even though the default server under NAT was set as my ISA server. I upgraded the firmware on the router and setup the port forwarding and the website started working.

Your help was invaluable

Many Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Forefront ISA Server

From novice to tech pro — start learning today.