Outlook 2003 RPC over HTTP with Exchange 2007

We have a couple users still using Outlook 2003, they are frequently off site. We have setup their profiles with RPC over HTTP. (Outlook Anywhere) The problem is when they are in the building their Outlook seems to only connect via HTTPS and will not connect locally via TCP.

This causes some significant delays. Their settings have the box unchecked for "on fast networks connect with HTTP first" but as you can see by the image below it still only connects via HTTPS. The only way around this is to uncheck the Outlook over RPC options on the connections tab. Once that is done when they launch Outlook it connects via TCP fine right away.

What would cause this? We have an Exchange 2007 server. I have a feeling it's related to Outlook 2003 because anyone who uses Outlook 2007 does not have this problem.

Also their PC's are not members of the domain but that shouldn't matter should it? They are frequently offsite at customer locations and are constantly joining work groups so they do not want to be joined to the domain.
Outlook-HTTPS.jpg
bkpierceAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
kieran_bConnect With a Mentor Commented:
Are their workstations setup to use external DNS servers by chance?  Perhaps hosts files?

If you ping remote.domain.com from the problem workstations, what do you get.
0
 
bkpierceAuthor Commented:
Also while in the building connected via HTTPS they frequently lose their connection to the server. We tried increasing the timeout but it will just hang on trying to connect..
0
 
kieran_bCommented:
Is your internal DNS setup properly so that when they are in the office and ping mail.yourdomain.com (the same as RPC/HTTP is setup with) that it redirects to the internal IP?

Judging by that screenshot, I would expect not.
0
Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

 
bkpierceAuthor Commented:
Yes, our SSL cert is for remote.domain.com (SBS Server). That is in our internal DNS, when I try to ping it it replies back from the internal IP address of the Exchange Server.

I went to testexchangeconnectivity.com and ran the Outlook Anywhere remote connectivity test and everything came back OK except for one thing. (Screen shot below). It gives a link to a MS site and says to check

- The registry for a valid ports in HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\Rpcproxy, everything was OK here

- Try and telnet to ports 6001, 6002 and 6004 - I was able to telnet to all 3 ports on the server


RPC-Endpoint.jpg
0
 
bkpierceAuthor Commented:
When the users ping remote.domain.com they are getting a reply from the internal IP address of the Exchange server. One of them has a hosts file in use but it does not have any references to our remote.domain.com.

When they launch Outlook it's still connecting via HTTP instead of TCP, very confusing.
0
 
kieran_bCommented:
And this is only outlook 2003?

Can you put a screenshot of the RPC/HTTP page from outlook (in mailbox settings, more options, connection, rpc/http)

I have seen Outlook 2003 want mutual authentication sometimes, other than that it is a headscratcher.
0
 
bkpierceAuthor Commented:
Here is a screen shot of RPC over HTTPS settings, I blacked out our domain but everything should be connected with these settings. I'm not sure why they only connect via HTTPS when in the office instead of TCP
RPC-over-HTTP.jpg
0
 
Shreedhar EtteCommented:
Hi,

Make sure the valid ports registry points this:

servername:6001-6002;serverfqdn:6001-6002;remote.abc.com:6001-6002;servername:6004;serverfqdn:6004;remote.abc.com:6004

If it is not pointing as this mentioned above then make the changes and reboot the server. After that test the Outlook Anywhere from the Outlook.

I hope this helps,
Shree
0
 
bkpierceAuthor Commented:
The registry looked ok and I am able to telnet to all those ports.

I have a feeling it has something to do with Outlook 2003, anyone running Outlook 2007 does not have the problem.
0
 
kieran_bCommented:
That is quite weird...

The only other thing i can think of is to untick the "for slow networks" option (it shouldn't matter, but still) and finally, untick the option to mutually authenticate, just to see what it does.
0
 
bkpierceAuthor Commented:
User had an external DNS server is his static IP configuration, sometimes it's the easiest things.
0
 
kieran_bCommented:
Did you resolve this?  If you did, I'd love to know what it was - if it was something other than what was posted, that could be useful for the next person with this problem
0
 
bkpierceAuthor Commented:
Yeah, I put it in the solution, the user had an external DNS server in his configuration. He had Yahoo's DNS instead of our DNS server in there.
0
 
kieran_bCommented:
Ah sorry, I didn't notice that.

Glad you got it sorted.
0
All Courses

From novice to tech pro — start learning today.